aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-11-03 20:23:41 -0600
committerTed Gould <ted@canonical.com>2009-11-03 20:23:41 -0600
commit541f18ceb56e3db6d342ae3dbac51e527592614e (patch)
tree41ddb409dfbc7b4b905d9f57d6e7c8403c8220fa /configure.ac
parentb5f41d1c0ca30f1cf7379e754d906681ccfbe9e1 (diff)
parentc09917d4792ccbd9fbd773874ae6e75e73c32a6e (diff)
downloadlibayatana-indicator-541f18ceb56e3db6d342ae3dbac51e527592614e.tar.gz
libayatana-indicator-541f18ceb56e3db6d342ae3dbac51e527592614e.tar.bz2
libayatana-indicator-541f18ceb56e3db6d342ae3dbac51e527592614e.zip
Merging in an interface for loading modules cleanly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 090e281..d2e18fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,19 @@ AC_CONFIG_MACRO_DIR([m4])
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
##############################
+# Dependencies
+##############################
+
+GTK_REQUIRED_VERSION=2.18
+DBUS_REQUIRED_VERSION=0.76
+
+PKG_CHECK_MODULES(LIBINDICATOR, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ dbus-glib-1 >= $DBUS_REQUIRED_VERSION)
+
+AC_SUBST(LIBINDICATOR_CFLAGS)
+AC_SUBST(LIBINDICATOR_LIBS)
+
+##############################
# Custom Junk
##############################
@@ -73,6 +86,8 @@ AC_OUTPUT([
Makefile
libindicator/Makefile
libindicator/indicator.pc
+tests/Makefile
+tools/Makefile
])
###########################