aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-01-24 10:07:33 -0600
committerTed Gould <ted@gould.cx>2012-01-24 10:07:33 -0600
commite81d0ecfe1899acc60fb50a5fbc03823a132139d (patch)
tree5cc88f8d0aaca8690e7323fad06448fb6bf2403f /configure.ac
parente36cd22ea84365df4797fc2588fe639ffda4daf6 (diff)
parentdbccdd5fd7c0850af8ffd411f906dc43785e599b (diff)
downloadlibayatana-indicator-e81d0ecfe1899acc60fb50a5fbc03823a132139d.tar.gz
libayatana-indicator-e81d0ecfe1899acc60fb50a5fbc03823a132139d.tar.bz2
libayatana-indicator-e81d0ecfe1899acc60fb50a5fbc03823a132139d.zip
Import upstream version 0.4.90
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2357f13..e881de0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_INIT([libindicator],
- [0.4.1],
+ [0.4.90],
[http://bugs.launchpad.net/libindicator],
[libindicator],
[http://launchpad.net/libindicator])
@@ -108,6 +108,14 @@ AC_DEFINE_PATH(SYSCONFDIR, "${sysconfdir}", [system configuration dir])
AC_DEFINE_PATH(LIBDIR, "${libdir}", [system configuration dir])
#########################
+# Check if build tests
+#########################
+AC_ARG_ENABLE([tests],
+ AC_HELP_STRING([--disable-tests], [disable tests]),,
+ [enable_tests=yes])
+AM_CONDITIONAL([WANT_TESTS], [test "x$enable_tests" != "xno"])
+
+#########################
# Debug symbols
#########################
AC_ARG_ENABLE([debug],
@@ -122,6 +130,15 @@ fi
AM_CONDITIONAL(ENABLE_DEBUG, test "$enable_debug" = "yes")
###########################
+# gcov coverage reporting
+###########################
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Files
###########################
@@ -146,5 +163,7 @@ Libindicator Configuration:
Prefix: $prefix
GTK+ Version: $with_gtk
+ Enable tests: $enable_tests
Enable debugging: $enable_debug
+ Coverage reporting: $use_gcov
])