aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2013-05-23 09:04:13 -0400
committerLars Uebernickel <lars.uebernickel@canonical.com>2013-05-23 09:04:13 -0400
commita5913055316b1d2efe05435db3ed78898e8042d9 (patch)
tree46ae31358b6b0d4a209bb60c6ae09ce7e139c211 /configure.ac
parentf77f41e21ade7d44ede8c990959807adf77a430b (diff)
downloadlibayatana-indicator-a5913055316b1d2efe05435db3ed78898e8042d9.tar.gz
libayatana-indicator-a5913055316b1d2efe05435db3ed78898e8042d9.tar.bz2
libayatana-indicator-a5913055316b1d2efe05435db3ed78898e8042d9.zip
Depend on ido and call ido_init() in indicator-loader
Ido provides the custom menu items that indicator services request. ido_init() registers those items with gtk+, so that they'll be created from gtk_menu_new_from_model().
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3dc40f1..698d64b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,7 @@ AS_IF([test "x$enable_deprecations" = xno],
GTK_REQUIRED_VERSION=2.18
GTK3_REQUIRED_VERSION=3.6
GIO_UNIX_REQUIRED_VERSION=2.37
+IDO_REQUIRED_VERSION=13.10.0
AC_ARG_WITH([gtk],
[AS_HELP_STRING([--with-gtk],
@@ -54,7 +55,8 @@ AC_ARG_WITH([gtk],
AS_IF([test "x$with_gtk" = x3],
[PKG_CHECK_MODULES(LIBINDICATOR, gtk+-3.0 >= $GTK3_REQUIRED_VERSION
gmodule-2.0
- gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION)
+ gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION
+ libido3-0.1 >= $IDO_REQUIRED_VERSION)
],
[test "x$with_gtk" = x2],
[PKG_CHECK_MODULES(LIBINDICATOR, gtk+-2.0 >= $GTK_REQUIRED_VERSION