aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan LeSage <allanlesage@gmail.com>2011-12-06 15:21:45 -0600
committerAllan LeSage <allanlesage@gmail.com>2011-12-06 15:21:45 -0600
commitb1aebe568a4f0d0d76e9ea32df47385b26b45c5d (patch)
treed9df684d7a831f1cffb262f39b580144ac648730 /configure.ac
parenta5c78749b6a655f3f54d2d9f69302b11d53a3059 (diff)
downloadlibayatana-indicator-b1aebe568a4f0d0d76e9ea32df47385b26b45c5d.tar.gz
libayatana-indicator-b1aebe568a4f0d0d76e9ea32df47385b26b45c5d.tar.bz2
libayatana-indicator-b1aebe568a4f0d0d76e9ea32df47385b26b45c5d.zip
Added coverage reporting via gcov config and targets.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2357f13..42a476a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,6 +122,15 @@ fi
AM_CONDITIONAL(ENABLE_DEBUG, test "$enable_debug" = "yes")
###########################
+# gcov coverage reporting
+###########################
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Files
###########################
@@ -147,4 +156,5 @@ Libindicator Configuration:
GTK+ Version: $with_gtk
Enable debugging: $enable_debug
+ Coverage reporting: $use_gcov
])