aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-01-13 16:09:40 +0100
committerTed Gould <ted@gould.cx>2012-01-13 16:09:40 +0100
commite3ce5513c45374858d9af5ae82ff9a711b6cf2aa (patch)
treebefdb9f53cd8fd29e5bb3db9bace971d9998d7ba /configure.ac
parent976209fbb36c9b09a59c8d51da80ae065cca8192 (diff)
parentb1aebe568a4f0d0d76e9ea32df47385b26b45c5d (diff)
downloadlibayatana-indicator-e3ce5513c45374858d9af5ae82ff9a711b6cf2aa.tar.gz
libayatana-indicator-e3ce5513c45374858d9af5ae82ff9a711b6cf2aa.tar.bz2
libayatana-indicator-e3ce5513c45374858d9af5ae82ff9a711b6cf2aa.zip
Adding test coverage checking
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a2c39b5..4710901 100644
--- a/configure.ac
+++ b/configure.ac
@@ -130,6 +130,15 @@ fi
AM_CONDITIONAL(ENABLE_DEBUG, test "$enable_debug" = "yes")
###########################
+# gcov coverage reporting
+###########################
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Files
###########################
@@ -156,4 +165,5 @@ Libindicator Configuration:
Enable tests: $enable_tests
Enable debugging: $enable_debug
+ Coverage reporting: $use_gcov
])