aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-01-23 08:55:12 -0600
committerCharles Kerr <charles.kerr@canonical.com>2012-01-23 08:55:12 -0600
commit95daf102dac37a69686f8a86bf7fe47cd442c7d6 (patch)
tree3891a7075873c6eeb320fe0c8a572ca14655f5af /configure.ac
parent4f4190f71f8495e5bcf6779d73157931572e42ac (diff)
parent1cf6a9761db8beefc8d2a73c2cf9903264424c66 (diff)
downloadlibayatana-indicator-95daf102dac37a69686f8a86bf7fe47cd442c7d6.tar.gz
libayatana-indicator-95daf102dac37a69686f8a86bf7fe47cd442c7d6.tar.bz2
libayatana-indicator-95daf102dac37a69686f8a86bf7fe47cd442c7d6.zip
"bzr merge lp:indicator" + conflict resolution in tests suite
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2357f13..4710901 100644
--- a/configure.ac
+++ b/configure.ac
@@ -108,6 +108,14 @@ AC_DEFINE_PATH(SYSCONFDIR, "${sysconfdir}", [system configuration dir])
AC_DEFINE_PATH(LIBDIR, "${libdir}", [system configuration dir])
#########################
+# Check if build tests
+#########################
+AC_ARG_ENABLE([tests],
+ AC_HELP_STRING([--disable-tests], [disable tests]),,
+ [enable_tests=yes])
+AM_CONDITIONAL([WANT_TESTS], [test "x$enable_tests" != "xno"])
+
+#########################
# Debug symbols
#########################
AC_ARG_ENABLE([debug],
@@ -122,6 +130,15 @@ fi
AM_CONDITIONAL(ENABLE_DEBUG, test "$enable_debug" = "yes")
###########################
+# gcov coverage reporting
+###########################
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Files
###########################
@@ -146,5 +163,7 @@ Libindicator Configuration:
Prefix: $prefix
GTK+ Version: $with_gtk
+ Enable tests: $enable_tests
Enable debugging: $enable_debug
+ Coverage reporting: $use_gcov
])