aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-02-14 14:21:36 -0600
committerTed Gould <ted@gould.cx>2012-02-14 14:21:36 -0600
commiteb803e833096843fa14705494cb91b0adf96fff7 (patch)
tree0762fdab61aa1e6865dda9e9f81c74a233713fe5 /configure.ac
parentb2a5f94bf7807e640d8b11dc33e0025c0f2036d5 (diff)
parent45aebde8abddd54f52333fd9cd2462eb0497f5dc (diff)
downloadlibayatana-indicator-eb803e833096843fa14705494cb91b0adf96fff7.tar.gz
libayatana-indicator-eb803e833096843fa14705494cb91b0adf96fff7.tar.bz2
libayatana-indicator-eb803e833096843fa14705494cb91b0adf96fff7.zip
* Upstream Merge
* Explicitly add in gmodule as a required library
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38dd416..3f33d52 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,10 +52,12 @@ AC_ARG_WITH([gtk],
[with_gtk=3])
AS_IF([test "x$with_gtk" = x3],
[PKG_CHECK_MODULES(LIBINDICATOR, gtk+-3.0 >= $GTK3_REQUIRED_VERSION
+ gmodule-2.0
gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION)
],
[test "x$with_gtk" = x2],
[PKG_CHECK_MODULES(LIBINDICATOR, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ gmodule-2.0
gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION)
],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]