aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-06-09 08:46:20 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-06-09 08:46:20 +0200
commita25c5f1645ec6cfbd490f65136552519989ef613 (patch)
tree7193e527be8a5a4145629fa3ec9936f4bcc0c671 /data/CMakeLists.txt
parent912f071d8a27dd547bc39e8763af155d9cdd0b47 (diff)
parentdea96ddc132b8e41fca53a3b4d72cb4a9462202d (diff)
downloadlibayatana-indicator-a25c5f1645ec6cfbd490f65136552519989ef613.tar.gz
libayatana-indicator-a25c5f1645ec6cfbd490f65136552519989ef613.tar.bz2
libayatana-indicator-a25c5f1645ec6cfbd490f65136552519989ef613.zip
Merge branch 'tari01-pr/cmake-install-full'
Attributes GH PR #48: https://github.com/AyatanaIndicators/libayatana-indicator/pull/48
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 2a60d05..74b48e6 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -6,10 +6,10 @@ if (FLAVOUR_GTK3)
else()
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicator3-no-IDO.pc.in" "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator3-0.${API_VERSION}.pc" @ONLY)
endif()
- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator3-0.${API_VERSION}.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/pkgconfig/")
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator3-0.${API_VERSION}.pc" DESTINATION "${CMAKE_INSTALL_FULL_LIBDIR}/pkgconfig/")
else()
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicator.pc.in" "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-0.${API_VERSION}.pc" @ONLY)
- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-0.${API_VERSION}.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/pkgconfig/")
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-0.${API_VERSION}.pc" DESTINATION "${CMAKE_INSTALL_FULL_LIBDIR}/pkgconfig/")
endif()
# ayatana-indicators.target (only required once, so let's do it with FLAVOUR_GTK3)
@@ -20,7 +20,7 @@ if (FLAVOUR_GTK3)
if (${SYSTEMD_FOUND})
if (${SYSTEMD_VERSION} VERSION_LESS 247)
- set(SYSTEMD_USER_UNIT_DIR ${CMAKE_INSTALL_PREFIX}/lib/systemd/user)
+ set(SYSTEMD_USER_UNIT_DIR "${CMAKE_INSTALL_FULL_LIBDIR}/systemd/user")
else()
pkg_get_variable(SYSTEMD_USER_UNIT_DIR systemd systemd_user_unit_dir)
endif()