aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-02-18 14:05:02 -0600
committerTed Gould <ted@canonical.com>2009-02-18 14:05:02 -0600
commit7aeff8efc7e25718569667fcb22f9508a087bb5d (patch)
tree297fdb7970857b3c6311bb0c8ff748d0eb66bb25 /data/Makefile.am
parent19665b4439136efaf34f410b453f06da27617dd8 (diff)
parent78a8495a3123d601b8fe3ae734168e992bc21188 (diff)
downloadlibayatana-indicator-7aeff8efc7e25718569667fcb22f9508a087bb5d.tar.gz
libayatana-indicator-7aeff8efc7e25718569667fcb22f9508a087bb5d.tar.bz2
libayatana-indicator-7aeff8efc7e25718569667fcb22f9508a087bb5d.zip
Merging in icon changes
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 7fc4a6f..a03fadc 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -32,6 +32,27 @@ schema_DATA = \
@INTLTOOL_SCHEMAS_RULE@
+##############################
+# Icons
+##############################
+
+iconsdir = $(datadir)/icons/hicolor/scalable/apps
+
+icons_DATA = indicator-applet.svg
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
##############################
# Autojunk
@@ -44,6 +65,7 @@ CLEANFILES = \
*.bak
EXTRA_DIST = \
+ $(icons_DATA) \
GNOME_IndicatorApplet.server.in.in \
$(schema_in_files)
@@ -58,3 +80,5 @@ else
install-data-local:
endif
+
+