aboutsummaryrefslogtreecommitdiff
path: root/libindicate-gtk/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-08-04 10:27:08 +0100
committerTed Gould <ted@canonical.com>2009-08-04 10:27:08 +0100
commit5909ee4172e2913f7ef65b4632c4a283431adae4 (patch)
tree977b8970244ec952fc55ddaf7a9cb9aec8e794e9 /libindicate-gtk/Makefile.am
parent064740bd411abe73a67a9c75f469f04d8259afdb (diff)
parent63ed0ba9f0de5d60f31e5c52849cb6fb7a070cd9 (diff)
downloadlibayatana-indicator-5909ee4172e2913f7ef65b4632c4a283431adae4.tar.gz
libayatana-indicator-5909ee4172e2913f7ef65b4632c4a283431adae4.tar.bz2
libayatana-indicator-5909ee4172e2913f7ef65b4632c4a283431adae4.zip
* Merging in upstream code to split out libindicate-gtk
* debian/control: * Changing the version number of libindcate to 2 to match the .so numbering. * Creating packages for libindicate-gtk * Added libindicate-gtk-dev.install and libindicate-gtk0.install for the new library. * Renamed libindicate1.install to libindicate2.install to match the package name change. * Modified libindicate-dev to be more specific about the header files that it grabs.
Diffstat (limited to 'libindicate-gtk/Makefile.am')
-rw-r--r--libindicate-gtk/Makefile.am72
1 files changed, 72 insertions, 0 deletions
diff --git a/libindicate-gtk/Makefile.am b/libindicate-gtk/Makefile.am
new file mode 100644
index 0000000..2085b47
--- /dev/null
+++ b/libindicate-gtk/Makefile.am
@@ -0,0 +1,72 @@
+
+INCLUDES= \
+ -DG_LOG_DOMAIN=\"libindicate-gtk\"
+
+EXTRA_DIST = \
+ indicate-gtk.pc.in
+
+lib_LTLIBRARIES = \
+ libindicate-gtk.la
+
+libindicate_gtkincludedir=$(includedir)/libindicate-0.1/libindicate-gtk
+
+indicate_gtk_headers = \
+ indicator.h \
+ listener.h
+
+libindicate_gtkinclude_HEADERS = \
+ $(indicate_gtk_headers)
+
+libindicate_gtk_la_SOURCES = \
+ $(indicate_gtk_headers) \
+ indicator.c \
+ listener.c
+
+libindicate_gtk_la_LDFLAGS = \
+ -version-info $(LIBINDICATEGTK_CURRENT):$(LIBINDICATEGTK_REVISION):$(LIBINDICATEGTK_AGE) \
+ -no-undefined \
+ -export-symbols-regex "^[^_d].*"
+
+libindicate_gtk_la_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(LIBINDICATEGTK_CFLAGS)
+
+libindicate_gtk_la_LIBADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATEGTK_LIBS)
+
+pkgconfig_DATA = indicate-gtk.pc
+pkgconfigdir = $(libdir)/pkgconfig
+
+if USE_GIR
+
+gobjectintrospection_gir_DATA = \
+ Indicate-gtk-0.1.gir
+gobjectintrospection_girdir = $(datadir)/gir
+
+gobjectintrospection_type_DATA = \
+ Indicate-gtk-0.1.typelib
+gobjectintrospection_typedir = $(libdir)/girepository
+
+irscanner_headers = $(patsubst %,$(srcdir)/%,$(indicate_headers))
+Indicate-gtk-0.1.gir: $(irscanner_headers)
+ $(G_IR_SCANNER) \
+ -v --namespace IndicateGtk \
+ --nsversion=0.1 \
+ --add-include-path=$(srcdir) \
+ --include=GObject-2.0 \
+ --include=GLib-2.0 \
+ --include=GdkPixbuf-2.0 \
+ --library=indicate --pkg indicate \
+ --output Indicate-gtk-0.1.gir $(irscanner_headers)
+
+Indicate-gtk-0.1.typelib: Indicate-gtk-0.1.gir
+ $(G_IR_COMPILER) \
+ --includedir=$(srcdir) Indicate-gtk-0.1.gir \
+ -o Indicate-gtk-0.1.typelib
+
+DISTCLEANFILES = \
+ Indicate-gtk-0.1.gir \
+ Indicate-gtk-0.1.typelib
+
+endif