aboutsummaryrefslogtreecommitdiff
path: root/libindicate/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-01-07 17:42:44 -0600
committerTed Gould <ted@canonical.com>2009-01-07 17:42:44 -0600
commit320643474fc86602e0ec84c9d87237562f3e7309 (patch)
treede16c06ed45e3fb5e123caa7e5e13f255e170806 /libindicate/Makefile.am
parentcd42ea20bfad6d7e8daf51c34f57a4200f811c1f (diff)
downloadlibayatana-indicator-320643474fc86602e0ec84c9d87237562f3e7309.tar.gz
libayatana-indicator-320643474fc86602e0ec84c9d87237562f3e7309.tar.bz2
libayatana-indicator-320643474fc86602e0ec84c9d87237562f3e7309.zip
Make file starting out to build this thing
Diffstat (limited to 'libindicate/Makefile.am')
-rw-r--r--libindicate/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/libindicate/Makefile.am b/libindicate/Makefile.am
new file mode 100644
index 0000000..f54be07
--- /dev/null
+++ b/libindicate/Makefile.am
@@ -0,0 +1,33 @@
+
+INCLUDES= \
+ -DG_LOG_DOMAIN=\"indicate\"
+
+EXTRA_DIST = \
+ indicate-server.xml
+
+libindicateincludedir=$(includedir)/libindicate-1.0/libindicate
+
+indicate_headers = \
+ indicator.h \
+ server.h
+
+libindicateinclude_HEADERS = \
+ $(indicate_headers)
+
+libindicate_SOURCES = \
+ $(indicate_headers) \
+ dbus-indicate-server.h
+ server.c \
+ indicator.c
+
+libindicate_LDFLAGS = \
+ -version-info 0:0:1 \
+ -no-undefined \
+ -export-symbols-regex "^[^_].*"
+
+dbus-indicate-server.h: indicate-server.xml
+ libtool --mode=execute dbus-binding-tool \
+ --prefix=indicate_server \
+ --mode=glib-server \
+ --output=dbus-indicate-server.h \
+ $(srcdir)/indicate-server.xml