aboutsummaryrefslogtreecommitdiff
path: root/libindicate/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-01-16 16:21:09 -0600
committerTed Gould <ted@canonical.com>2009-01-16 16:21:09 -0600
commitac140d5000a6f6698f5b7d690ba48c877472c054 (patch)
tree464ee8f3babdc7793e4e4f3339d677165b8e5f84 /libindicate/Makefile.am
parente83283e29941c9f6e4a0b20cc179c846edf7dc47 (diff)
downloadlibayatana-indicator-ac140d5000a6f6698f5b7d690ba48c877472c054.tar.gz
libayatana-indicator-ac140d5000a6f6698f5b7d690ba48c877472c054.tar.bz2
libayatana-indicator-ac140d5000a6f6698f5b7d690ba48c877472c054.zip
Bringing GObject Introspection into the build and making it so that
it gets installed with the library.
Diffstat (limited to 'libindicate/Makefile.am')
-rw-r--r--libindicate/Makefile.am35
1 files changed, 31 insertions, 4 deletions
diff --git a/libindicate/Makefile.am b/libindicate/Makefile.am
index d2a0811..53cb273 100644
--- a/libindicate/Makefile.am
+++ b/libindicate/Makefile.am
@@ -46,28 +46,55 @@ libindicate_la_LIBADD = \
$(LIBINDICATE_LIBS)
dbus-indicate-server.h: indicate-interface.xml
- libtool --mode=execute dbus-binding-tool \
+ dbus-binding-tool \
--prefix=indicate_server \
--mode=glib-server \
--output=dbus-indicate-server.h \
$(srcdir)/indicate-interface.xml
dbus-indicate-client.h: indicate-interface.xml
- libtool --mode=execute dbus-binding-tool \
+ dbus-binding-tool \
--prefix=indicate_client \
--mode=glib-client \
--output=dbus-indicate-client.h \
$(srcdir)/indicate-interface.xml
listener-marshal.h: listener-marshal.list
- libtool --mode=execute glib-genmarshal --header \
+ glib-genmarshal --header \
--prefix=indicate_listener_marshal $(srcdir)/listener-marshal.list \
> listener-marshal.h
listener-marshal.c: listener-marshal.list
- libtool --mode=execute glib-genmarshal --body \
+ glib-genmarshal --body \
--prefix=indicate_listener_marshal $(srcdir)/listener-marshal.list \
> listener-marshal.c
pkgconfig_DATA = indicate.pc
pkgconfigdir = $(libdir)/pkgconfig
+
+gobjectintrospection_gir_DATA = \
+ Indicate-0.1.gir
+gobjectintrospection_girdir = $(datadir)/gir
+
+gobjectintrospection_type_DATA = \
+ Indicate-0.1.typelib
+gobjectintrospection_typedir = $(libdir)/girepository
+
+irscanner_headers = $(patsubst %,$(srcdir)/%,$(indicate_headers))
+Indicate-0.1.gir: $(irscanner_headers)
+ $(G_IR_SCANNER) \
+ -v --namespace Indicate \
+ --nsversion=0.1 \
+ --add-include-path=$(srcdir) \
+ --include=GObject-2.0 \
+ --include=GLib-2.0 \
+ --include=DBus-1.0 \
+ --include=DBusGLib-1.0 \
+ --library=indicate --pkg indicate \
+ --output Indicate-0.1.gir $(irscanner_headers)
+
+Indicate-0.1.typelib: Indicate-0.1.gir
+ $(G_IR_COMPILER) \
+ --includedir=$(srcdir) Indicate-0.1.gir \
+ -o Indicate-0.1.typelib
+