aboutsummaryrefslogtreecommitdiff
path: root/libindicate/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-01-15 19:49:23 -0600
committerTed Gould <ted@canonical.com>2009-01-15 19:49:23 -0600
commite50f228a7e4116c902a992a12ce9332c4481bf4c (patch)
treeefb5a67ccdebe2c65cb9e16adac75b47f846a318 /libindicate/Makefile.am
parentd1c2ed2c5ccdfefc8c63e591a1742d8d61f310c4 (diff)
downloadlibayatana-indicator-e50f228a7e4116c902a992a12ce9332c4481bf4c.tar.gz
libayatana-indicator-e50f228a7e4116c902a992a12ce9332c4481bf4c.tar.bz2
libayatana-indicator-e50f228a7e4116c902a992a12ce9332c4481bf4c.zip
Adding in a marshaller for the DBus signals that we need
Diffstat (limited to 'libindicate/Makefile.am')
-rw-r--r--libindicate/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/libindicate/Makefile.am b/libindicate/Makefile.am
index b3c173a..53917b7 100644
--- a/libindicate/Makefile.am
+++ b/libindicate/Makefile.am
@@ -9,7 +9,9 @@ EXTRA_DIST = \
BUILT_SOURCES = \
dbus-indicate-server.h \
- dbus-indicate-client.h
+ dbus-indicate-client.h \
+ listener-marshal.c \
+ listener-marshal.h
lib_LTLIBRARIES = \
libindicate.la
@@ -30,6 +32,8 @@ libindicate_la_SOURCES = \
dbus-indicate-client.h \
server.c \
listener.c \
+ listener-marshal.c \
+ listener-marshal.h \
indicator.c
libindicate_la_LDFLAGS = \
@@ -57,5 +61,15 @@ dbus-indicate-client.h: indicate-interface.xml
--output=dbus-indicate-client.h \
$(srcdir)/indicate-interface.xml
+listener-marshal.h: listener-marshal.list
+ libtool --mode=execute glib-genmarshal --header \
+ --prefix=indicate_listener_marshal $(srcdir)/listener-marshal.list \
+ > listener-marshal.h
+
+listener-marshal.c: listener-marshal.list
+ libtool --mode=execute glib-genmarshal --body \
+ --prefix=indicate_listener_marshal $(srcdir)/listener-marshal.list \
+ > listener-marshal.c
+
pkgconfig_DATA = indicate.pc
pkgconfigdir = $(libdir)/pkgconfig