aboutsummaryrefslogtreecommitdiff
path: root/libindicate/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-04-03 11:32:35 -0500
committerTed Gould <ted@canonical.com>2009-04-03 11:32:35 -0500
commitbe4c00257d32c9d26407f10384ef78837b2c1fe0 (patch)
tree258c510d6138b68006f4aba218b69e00ece1b584 /libindicate/Makefile.am
parent303c52b3167cd943a2a84e55f562c39daf1e4d6f (diff)
downloadlibayatana-indicator-be4c00257d32c9d26407f10384ef78837b2c1fe0.tar.gz
libayatana-indicator-be4c00257d32c9d26407f10384ef78837b2c1fe0.tar.bz2
libayatana-indicator-be4c00257d32c9d26407f10384ef78837b2c1fe0.zip
Hiding the marshsallers from the libraries in the symbols by adding a _ in front of them.
Diffstat (limited to 'libindicate/Makefile.am')
-rw-r--r--libindicate/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libindicate/Makefile.am b/libindicate/Makefile.am
index aff9ffc..f48ad1f 100644
--- a/libindicate/Makefile.am
+++ b/libindicate/Makefile.am
@@ -86,12 +86,12 @@ dbus-listener-client.h: indicate-listener.xml
listener-marshal.h: $(srcdir)/listener-marshal.list
glib-genmarshal --header \
- --prefix=indicate_listener_marshal $(srcdir)/listener-marshal.list \
+ --prefix=_indicate_listener_marshal $(srcdir)/listener-marshal.list \
> listener-marshal.h
listener-marshal.c: $(srcdir)/listener-marshal.list
glib-genmarshal --body \
- --prefix=indicate_listener_marshal $(srcdir)/listener-marshal.list \
+ --prefix=_indicate_listener_marshal $(srcdir)/listener-marshal.list \
> listener-marshal.c
pkgconfig_DATA = indicate.pc