aboutsummaryrefslogtreecommitdiff
path: root/libindicate/Makefile.am
diff options
context:
space:
mode:
authorseb128 <seb128@seb128-desktop>2009-03-16 23:22:15 +0100
committerseb128 <seb128@seb128-desktop>2009-03-16 23:22:15 +0100
commitdeccbbbcacf975b79d2a6586767dddd8d1962b14 (patch)
treee6f35e7c909b9f8d5c2b5f1c144deea9224398f3 /libindicate/Makefile.am
parent3bc5b8e8105d698e7782c8090148dbe8f135161f (diff)
parentdab5af7f6bbfdb69e62b8378b6c8770ffe542c06 (diff)
downloadlibayatana-indicator-deccbbbcacf975b79d2a6586767dddd8d1962b14.tar.gz
libayatana-indicator-deccbbbcacf975b79d2a6586767dddd8d1962b14.tar.bz2
libayatana-indicator-deccbbbcacf975b79d2a6586767dddd8d1962b14.zip
indicator-applet (0.1.2-0ubuntu1) jaunty; urgency=low
* New upstream version * Removes duplicate prototypes (LP: #338885) * Fixes background color to match them on dark themes when the panel color is not set (LP: #334490) * Removing the handle and replacing it with the ability to right click on the applet to get a panel menu (LP: #339818) * Various build fixes -- Ted Gould <ted@ubuntu.com>Sun, 15 Mar 2009 08:58:20 -0500
Diffstat (limited to 'libindicate/Makefile.am')
-rw-r--r--libindicate/Makefile.am71
1 files changed, 47 insertions, 24 deletions
diff --git a/libindicate/Makefile.am b/libindicate/Makefile.am
index 707d297..b851919 100644
--- a/libindicate/Makefile.am
+++ b/libindicate/Makefile.am
@@ -4,12 +4,15 @@ INCLUDES= \
EXTRA_DIST = \
indicate-interface.xml \
+ indicate-listener.xml \
listener-marshal.list \
indicate.pc.in
BUILT_SOURCES = \
dbus-indicate-server.h \
dbus-indicate-client.h \
+ dbus-listener-server.h \
+ dbus-listener-client.h \
listener-marshal.c \
listener-marshal.h
@@ -31,6 +34,8 @@ libindicate_la_SOURCES = \
$(indicate_headers) \
dbus-indicate-server.h \
dbus-indicate-client.h \
+ dbus-listener-server.h \
+ dbus-listener-client.h \
server.c \
listener.c \
listener-marshal.c \
@@ -63,6 +68,20 @@ dbus-indicate-client.h: indicate-interface.xml
--output=dbus-indicate-client.h \
$(srcdir)/indicate-interface.xml
+dbus-listener-server.h: indicate-listener.xml
+ dbus-binding-tool \
+ --prefix=indicate_listener \
+ --mode=glib-server \
+ --output=dbus-listener-server.h \
+ $(srcdir)/indicate-listener.xml
+
+dbus-listener-client.h: indicate-listener.xml
+ dbus-binding-tool \
+ --prefix=indicate_listener \
+ --mode=glib-client \
+ --output=dbus-listener-client.h \
+ $(srcdir)/indicate-listener.xml
+
listener-marshal.h: $(srcdir)/listener-marshal.list
glib-genmarshal --header \
--prefix=indicate_listener_marshal $(srcdir)/listener-marshal.list \
@@ -76,28 +95,32 @@ listener-marshal.c: $(srcdir)/listener-marshal.list
pkgconfig_DATA = indicate.pc
pkgconfigdir = $(libdir)/pkgconfig
-#gobjectintrospection_gir_DATA = \
-# Indicate-0.1.gir
-#gobjectintrospection_girdir = $(datadir)/gir
-#
-#gobjectintrospection_type_DATA = \
-# Indicate-0.1.typelib
-#gobjectintrospection_typedir = $(libdir)/girepository
-#
-#irscanner_headers = $(patsubst %,$(srcdir)/%,$(indicate_headers))
-#Indicate-0.1.gir: $(irscanner_headers)
-# $(G_IR_SCANNER) \
-# -v --namespace Indicate \
-# --nsversion=0.1 \
-# --add-include-path=$(srcdir) \
-# --include=GObject-2.0 \
-# --include=GLib-2.0 \
-# --include=GdkPixbuf-2.0 \
-# --library=indicate --pkg indicate \
-# --output Indicate-0.1.gir $(irscanner_headers)
-#
-#Indicate-0.1.typelib: Indicate-0.1.gir
-# $(G_IR_COMPILER) \
-# --includedir=$(srcdir) Indicate-0.1.gir \
-# -o Indicate-0.1.typelib
+gobjectintrospection_gir_DATA = \
+ Indicate-0.1.gir
+gobjectintrospection_girdir = $(datadir)/gir
+
+gobjectintrospection_type_DATA = \
+ Indicate-0.1.typelib
+gobjectintrospection_typedir = $(libdir)/girepository
+
+irscanner_headers = $(patsubst %,$(srcdir)/%,$(indicate_headers))
+Indicate-0.1.gir: $(irscanner_headers)
+ $(G_IR_SCANNER) \
+ -v --namespace Indicate \
+ --nsversion=0.1 \
+ --add-include-path=$(srcdir) \
+ --include=GObject-2.0 \
+ --include=GLib-2.0 \
+ --include=GdkPixbuf-2.0 \
+ --library=indicate --pkg indicate \
+ --output Indicate-0.1.gir $(irscanner_headers)
+
+Indicate-0.1.typelib: Indicate-0.1.gir
+ $(G_IR_COMPILER) \
+ --includedir=$(srcdir) Indicate-0.1.gir \
+ -o Indicate-0.1.typelib
+
+DISTCLEANFILES = \
+ Indicate-0.1.gir \
+ Indicate-0.1.typelib