aboutsummaryrefslogtreecommitdiff
path: root/libindicator/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2010-03-18 15:05:20 -0400
committerKen VanDine <ken.vandine@canonical.com>2010-03-18 15:05:20 -0400
commit947d4cf2cebbb6a94879c7795a6392d9b2eb723b (patch)
treea640073dc050b748b4b30d264a58912ebf5e6693 /libindicator/Makefile.am
parenta68b0e81fd88b54b019ab32d5745b7f2a3d756d3 (diff)
parentf07a2dff0b358a94d30908cb2f9cd66c13cf4afc (diff)
downloadlibayatana-indicator-947d4cf2cebbb6a94879c7795a6392d9b2eb723b.tar.gz
libayatana-indicator-947d4cf2cebbb6a94879c7795a6392d9b2eb723b.tar.bz2
libayatana-indicator-947d4cf2cebbb6a94879c7795a6392d9b2eb723b.zip
* Upstream release 0.3.6
* Adding in scroll signals for the indicators * debian/rules: Updating shlibs
Diffstat (limited to 'libindicator/Makefile.am')
-rw-r--r--libindicator/Makefile.am30
1 files changed, 27 insertions, 3 deletions
diff --git a/libindicator/Makefile.am b/libindicator/Makefile.am
index 890160c..4b11a77 100644
--- a/libindicator/Makefile.am
+++ b/libindicator/Makefile.am
@@ -1,6 +1,6 @@
-BUILT_SOURCES =
-CLEANFILES =
-DISTCLEANFILES =
+BUILT_SOURCES = indicator-object-enum-types.h indicator-object-enum-types.c
+CLEANFILES =
+DISTCLEANFILES =
EXTRA_DIST = \
indicator.pc.in
@@ -26,6 +26,7 @@ libindicator_la_SOURCES = \
$(indicator_headers) \
dbus-shared.h \
indicator-object.c \
+ indicator-object-enum-types.c \
indicator-desktop-shortcuts.c \
indicator-image-helper.c \
indicator-object-marshal.h \
@@ -47,6 +48,29 @@ pkgconfigdir = $(libdir)/pkgconfig
glib_marshal_list = indicator-object-marshal.list
glib_marshal_prefix = _indicator_object_marshal
+indicator-object-enum-types.h: s-enum-types-h
+ @true
+s-enum-types-h: $(indicator_headers)
+ ( cd $(srcdir) && $(GLIB_MKENUMS) --template $(srcdir)/indicator-object-enum-types.h.template \
+ $(indicator_headers) ) >> tmp-indicator-object-enum-types.h \
+ && (cmp -s tmp-indicator-object-enum-types.h indicator-object-enum-types.h || cp tmp-indicator-object-enum-types.h indicator-object-enum-types.h ) \
+ && rm -f tmp-indicator-object-enum-types.h && echo timestamp > $(@F)
+
+indicator-object-enum-types.c: s-enum-types-c
+ @true
+s-enum-types-c: $(indicator_headers)
+ ( cd $(srcdir) && $(GLIB_MKENUMS) --template $(srcdir)/indicator-object-enum-types.c.template \
+ $(indicator_headers) ) > tmp-indicator-object-enum-types.c \
+ && (cmp -s tmp-indicator-object-enum-types.c indicator-object-enum-types.c || cp tmp-indicator-object-enum-types.c indicator-object-enum-types.c ) \
+ && rm -f tmp-indicator-object-enum-types.c
+
+EXTRA_DIST += indicator-object-enum-types.h
+CLEANFILES += \
+ indicator-object-enum-types.h \
+ indicator-object-enum-types.c \
+ s-enum-types-h \
+ s-enum-types-c
+
##################################
# DBus Specs
##################################