aboutsummaryrefslogtreecommitdiff
path: root/libindicator/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-01-13 23:03:24 -0600
committerTed Gould <ted@gould.cx>2011-01-13 23:03:24 -0600
commitafe5430674b974d0cec6319e171e35b0f1d25d09 (patch)
treeb9cbd12ad5412b0be060ba2ce75e432a26a09663 /libindicator/Makefile.am
parentee32949d96d2c2243f4869c06d34d1d55031f411 (diff)
parent084d3e8ce7252629d9714179246ebb1b4b9af0ad (diff)
downloadlibayatana-indicator-afe5430674b974d0cec6319e171e35b0f1d25d09.tar.gz
libayatana-indicator-afe5430674b974d0cec6319e171e35b0f1d25d09.tar.bz2
libayatana-indicator-afe5430674b974d0cec6319e171e35b0f1d25d09.zip
Use dbus name watches instead of g-owner-change signal for watching for restarts.
Diffstat (limited to 'libindicator/Makefile.am')
-rw-r--r--libindicator/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libindicator/Makefile.am b/libindicator/Makefile.am
index 5c70345..47a902a 100644
--- a/libindicator/Makefile.am
+++ b/libindicator/Makefile.am
@@ -104,11 +104,11 @@ DBUS_SPECS = \
gen-%.xml.h: %.xml
@echo "Building $@ from $<"
- @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $<)));" > $@
+ @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@
gen-%.xml.c: %.xml
@echo "Building $@ from $<"
- @echo "const char * _$(subst -,_,$(subst .,_,$(basename $<))) = " > $@
+ echo "const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<)))) = " > $@
@sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
@echo ";" >> $@