aboutsummaryrefslogtreecommitdiff
path: root/libindicator/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-11-04 11:24:25 -0600
committerTed Gould <ted@canonical.com>2009-11-04 11:24:25 -0600
commit2b754cb1b6e7a69fd90f0d562e32e02204575561 (patch)
treefe779a4cf56532e520e6a88b1520321648465584 /libindicator/Makefile.am
parent534aab3aa87e4ffcca3e14f5c19498843c0adbca (diff)
parentc547687a407d935654aa71f7afa1e4392e50d5c5 (diff)
downloadlibayatana-indicator-2b754cb1b6e7a69fd90f0d562e32e02204575561.tar.gz
libayatana-indicator-2b754cb1b6e7a69fd90f0d562e32e02204575561.tar.bz2
libayatana-indicator-2b754cb1b6e7a69fd90f0d562e32e02204575561.zip
Updating to current trunk.
Diffstat (limited to 'libindicator/Makefile.am')
-rw-r--r--libindicator/Makefile.am39
1 files changed, 37 insertions, 2 deletions
diff --git a/libindicator/Makefile.am b/libindicator/Makefile.am
index db45f3c..5c512cd 100644
--- a/libindicator/Makefile.am
+++ b/libindicator/Makefile.am
@@ -1,3 +1,5 @@
+BUILT_SOURCES =
+CLEANFILES =
EXTRA_DIST = \
indicator.pc.in
@@ -5,7 +7,9 @@ libindicatorincludedir=$(includedir)/libindicator-0.1/libindicator
indicator_headers = \
indicator.h \
- indicator-object.h
+ indicator-object.h \
+ indicator-service.h \
+ indicator-service-manager.h
libindicatorinclude_HEADERS = \
$(indicator_headers)
@@ -15,7 +19,10 @@ lib_LTLIBRARIES = \
libindicator_la_SOURCES = \
$(indicator_headers) \
- indicator-object.c
+ dbus-shared.h \
+ indicator-object.c \
+ indicator-service.c \
+ indicator-service-manager.c
libindicator_la_CFLAGS = \
$(LIBINDICATOR_CFLAGS) \
@@ -27,3 +34,31 @@ libindicator_la_LIBADD = \
pkgconfig_DATA = indicator.pc
pkgconfigdir = $(libdir)/pkgconfig
+##################################
+# DBus Specs
+##################################
+
+DBUS_SPECS = \
+ indicator-service.xml
+
+%-client.h: %.xml
+ dbus-binding-tool \
+ --prefix=_$(subst -,_,$(basename $(notdir $<)))_client \
+ --mode=glib-client \
+ --output=$@ \
+ $<
+
+%-server.h: %.xml
+ dbus-binding-tool \
+ --prefix=_$(subst -,_,$(basename $(notdir $<)))_server \
+ --mode=glib-server \
+ --output=$@ \
+ $<
+
+BUILT_SOURCES += \
+ $(DBUS_SPECS:.xml=-client.h) \
+ $(DBUS_SPECS:.xml=-server.h)
+
+CLEANFILES += $(BUILT_SOURCES)
+
+EXTRA_DIST += $(DBUS_SPECS)