aboutsummaryrefslogtreecommitdiff
path: root/libindicator/Makefile.am
diff options
context:
space:
mode:
authorCody Russell <crussell@canonical.com>2010-03-16 11:40:14 -0500
committerCody Russell <crussell@canonical.com>2010-03-16 11:40:14 -0500
commit02d3dde87c8fcf2702741ab265dbaa24d498cd51 (patch)
treec059a878ed9b294cba4464e13c040d803621e899 /libindicator/Makefile.am
parent4adb9ab724e53a65603fe53abbb96304a8cab260 (diff)
downloadlibayatana-indicator-02d3dde87c8fcf2702741ab265dbaa24d498cd51.tar.gz
libayatana-indicator-02d3dde87c8fcf2702741ab265dbaa24d498cd51.tar.bz2
libayatana-indicator-02d3dde87c8fcf2702741ab265dbaa24d498cd51.zip
Define IndicatorScrollDirection enum for scroll signal parameter.
Diffstat (limited to 'libindicator/Makefile.am')
-rw-r--r--libindicator/Makefile.am30
1 files changed, 27 insertions, 3 deletions
diff --git a/libindicator/Makefile.am b/libindicator/Makefile.am
index 890160c..4b11a77 100644
--- a/libindicator/Makefile.am
+++ b/libindicator/Makefile.am
@@ -1,6 +1,6 @@
-BUILT_SOURCES =
-CLEANFILES =
-DISTCLEANFILES =
+BUILT_SOURCES = indicator-object-enum-types.h indicator-object-enum-types.c
+CLEANFILES =
+DISTCLEANFILES =
EXTRA_DIST = \
indicator.pc.in
@@ -26,6 +26,7 @@ libindicator_la_SOURCES = \
$(indicator_headers) \
dbus-shared.h \
indicator-object.c \
+ indicator-object-enum-types.c \
indicator-desktop-shortcuts.c \
indicator-image-helper.c \
indicator-object-marshal.h \
@@ -47,6 +48,29 @@ pkgconfigdir = $(libdir)/pkgconfig
glib_marshal_list = indicator-object-marshal.list
glib_marshal_prefix = _indicator_object_marshal
+indicator-object-enum-types.h: s-enum-types-h
+ @true
+s-enum-types-h: $(indicator_headers)
+ ( cd $(srcdir) && $(GLIB_MKENUMS) --template $(srcdir)/indicator-object-enum-types.h.template \
+ $(indicator_headers) ) >> tmp-indicator-object-enum-types.h \
+ && (cmp -s tmp-indicator-object-enum-types.h indicator-object-enum-types.h || cp tmp-indicator-object-enum-types.h indicator-object-enum-types.h ) \
+ && rm -f tmp-indicator-object-enum-types.h && echo timestamp > $(@F)
+
+indicator-object-enum-types.c: s-enum-types-c
+ @true
+s-enum-types-c: $(indicator_headers)
+ ( cd $(srcdir) && $(GLIB_MKENUMS) --template $(srcdir)/indicator-object-enum-types.c.template \
+ $(indicator_headers) ) > tmp-indicator-object-enum-types.c \
+ && (cmp -s tmp-indicator-object-enum-types.c indicator-object-enum-types.c || cp tmp-indicator-object-enum-types.c indicator-object-enum-types.c ) \
+ && rm -f tmp-indicator-object-enum-types.c
+
+EXTRA_DIST += indicator-object-enum-types.h
+CLEANFILES += \
+ indicator-object-enum-types.h \
+ indicator-object-enum-types.c \
+ s-enum-types-h \
+ s-enum-types-c
+
##################################
# DBus Specs
##################################