aboutsummaryrefslogtreecommitdiff
path: root/libindicator/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-01-10 10:17:04 -0600
committerTed Gould <ted@gould.cx>2011-01-10 10:17:04 -0600
commit48db67a55cf6d79ccc99a41cd512d5455f5d1925 (patch)
treeceb6c4999e33eb57cc16c1630c90cf50ad233dbd /libindicator/Makefile.am
parent2bf1edb3217caad1b15202070b44452d6fddf9f8 (diff)
parent4a3d68bb35a2f371708568e199bdb0fc92af4ef5 (diff)
downloadlibayatana-indicator-48db67a55cf6d79ccc99a41cd512d5455f5d1925.tar.gz
libayatana-indicator-48db67a55cf6d79ccc99a41cd512d5455f5d1925.tar.bz2
libayatana-indicator-48db67a55cf6d79ccc99a41cd512d5455f5d1925.zip
Porting to GDBus
Diffstat (limited to 'libindicator/Makefile.am')
-rw-r--r--libindicator/Makefile.am26
1 files changed, 12 insertions, 14 deletions
diff --git a/libindicator/Makefile.am b/libindicator/Makefile.am
index a799d8c..5c70345 100644
--- a/libindicator/Makefile.am
+++ b/libindicator/Makefile.am
@@ -31,6 +31,8 @@ libindicatorinclude_HEADERS = \
libindicator_la_SOURCES = \
$(indicator_headers) \
dbus-shared.h \
+ gen-indicator-service.xml.h \
+ gen-indicator-service.xml.c \
indicator-object.c \
indicator-object-enum-types.c \
indicator-desktop-shortcuts.c \
@@ -100,23 +102,19 @@ CLEANFILES += \
DBUS_SPECS = \
indicator-service.xml
-%-client.h: %.xml
- dbus-binding-tool \
- --prefix=_$(subst -,_,$(basename $(notdir $<)))_client \
- --mode=glib-client \
- --output=$@ \
- $<
+gen-%.xml.h: %.xml
+ @echo "Building $@ from $<"
+ @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $<)));" > $@
-%-server.h: %.xml
- dbus-binding-tool \
- --prefix=_$(subst -,_,$(basename $(notdir $<)))_server \
- --mode=glib-server \
- --output=$@ \
- $<
+gen-%.xml.c: %.xml
+ @echo "Building $@ from $<"
+ @echo "const char * _$(subst -,_,$(subst .,_,$(basename $<))) = " > $@
+ @sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
+ @echo ";" >> $@
BUILT_SOURCES += \
- $(DBUS_SPECS:.xml=-client.h) \
- $(DBUS_SPECS:.xml=-server.h)
+ gen-indicator-service.xml.h \
+ gen-indicator-service.xml.c
CLEANFILES += $(BUILT_SOURCES)