aboutsummaryrefslogtreecommitdiff
path: root/libindicator/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-01-24 10:10:15 -0600
committerTed Gould <ted@gould.cx>2012-01-24 10:10:15 -0600
commitb00b35ac30d54a4a16c87996afbec976c18e7a5b (patch)
treea1927111604579664770d15a0e75713959355b95 /libindicator/Makefile.am
parentfe22121bb429249b777bafa645e42120269249cf (diff)
parente81d0ecfe1899acc60fb50a5fbc03823a132139d (diff)
downloadlibayatana-indicator-b00b35ac30d54a4a16c87996afbec976c18e7a5b.tar.gz
libayatana-indicator-b00b35ac30d54a4a16c87996afbec976c18e7a5b.tar.bz2
libayatana-indicator-b00b35ac30d54a4a16c87996afbec976c18e7a5b.zip
* New upstream release.
* Support hiding and showing indicators * Track the parent object in the entry * Adding activate function to include Window ID
Diffstat (limited to 'libindicator/Makefile.am')
-rw-r--r--libindicator/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/libindicator/Makefile.am b/libindicator/Makefile.am
index 53f9985..ef6c6c7 100644
--- a/libindicator/Makefile.am
+++ b/libindicator/Makefile.am
@@ -13,7 +13,7 @@ EXTRA_DIST = \
indicator3-0.$(INDICATOR_API_VERSION).pc.in.in \
indicator-0.$(INDICATOR_API_VERSION).pc.in.in
-INDICATOR_ABI_VERSION = 6
+INDICATOR_ABI_VERSION = 7
INDICATOR_API_VERSION = 4
%.pc: %.pc.in
@@ -26,7 +26,7 @@ CLEANFILES += indicator$(VER)-0.$(INDICATOR_API_VERSION).pc
include $(top_srcdir)/Makefile.am.marshal
-libindicatorincludedir=$(includedir)/libindicator-0.$(INDICATOR_API_VERSION)/libindicator
+libindicatorincludedir=$(includedir)/libindicator$(VER)-0.$(INDICATOR_API_VERSION)/libindicator
indicator_headers = \
indicator.h \
@@ -55,6 +55,7 @@ libindicator_la_SOURCES = \
libindicator_la_CFLAGS = \
$(LIBINDICATOR_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-DG_LOG_DOMAIN=\"libindicator\" \
-Wall -Werror
@@ -62,6 +63,7 @@ libindicator_la_LIBADD = \
$(LIBINDICATOR_LIBS)
libindicator_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
-version-info $(INDICATOR_ABI_VERSION):0:0 \
-no-undefined \
-export-symbols-regex "^[^_].*"