aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-02-04 17:37:47 -0800
committerTed Gould <ted@gould.cx>2010-02-04 17:37:47 -0800
commit65bc7421edda0ffc4a8d5b36b5aea1d566522f6b (patch)
treed9f50fd9c288bbf7193e604ad15093415b8f25ac /tests/Makefile.am
parente0dbaa39db9ccf72a4dd9405d620a590ac751249 (diff)
parent0d5ea56677c20ba1f6cd9f8687d7c33b373c6db2 (diff)
downloadlibayatana-indicator-65bc7421edda0ffc4a8d5b36b5aea1d566522f6b.tar.gz
libayatana-indicator-65bc7421edda0ffc4a8d5b36b5aea1d566522f6b.tar.bz2
libayatana-indicator-65bc7421edda0ffc4a8d5b36b5aea1d566522f6b.zip
* Upstream release 0.3.2
* Various fixes to timeout handling in services and the * Fix test suite when run headless
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7fcccb6..b111655 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -10,6 +10,9 @@ lib_LTLIBRARIES = \
libdummy-indicator-simple.la
DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
+XVFB_RUN=". $(srcdir)/run-xvfb.sh"
+
+EXTRA_DIST = run-xvfb.sh
#############################
# Test Loader
@@ -297,7 +300,8 @@ XML_REPORT = loader-check-results.xml
HTML_REPORT = loader-check-results.html
loader-tester: test-loader libdummy-indicator-null.la libdummy-indicator-simple.la Makefile
- @echo "#!/bin/sh" > loader-tester
+ @echo "#!/bin/bash" > loader-tester
+ @echo $(XVFB_RUN) >> $@
@echo gtester -k --verbose -o=$(XML_REPORT) ./test-loader >> loader-tester
@chmod +x loader-tester