aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-02-02 13:16:42 -0800
committerTed Gould <ted@gould.cx>2010-02-02 13:16:42 -0800
commit6afee918e61effc297495027bf324e49e3d6c031 (patch)
treeb629589813b0aeb6ed2af713b9a199d93445b148 /tests/Makefile.am
parent103f8b0b79cfaf3e90e4ea01987485155b450d03 (diff)
parent527674dd6a94f1e9b0a558d6ac1a86593a8e787e (diff)
downloadlibayatana-indicator-6afee918e61effc297495027bf324e49e3d6c031.tar.gz
libayatana-indicator-6afee918e61effc297495027bf324e49e3d6c031.tar.bz2
libayatana-indicator-6afee918e61effc297495027bf324e49e3d6c031.zip
Fixes to the test suite.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7fcccb6..b111655 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -10,6 +10,9 @@ lib_LTLIBRARIES = \
libdummy-indicator-simple.la
DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
+XVFB_RUN=". $(srcdir)/run-xvfb.sh"
+
+EXTRA_DIST = run-xvfb.sh
#############################
# Test Loader
@@ -297,7 +300,8 @@ XML_REPORT = loader-check-results.xml
HTML_REPORT = loader-check-results.html
loader-tester: test-loader libdummy-indicator-null.la libdummy-indicator-simple.la Makefile
- @echo "#!/bin/sh" > loader-tester
+ @echo "#!/bin/bash" > loader-tester
+ @echo $(XVFB_RUN) >> $@
@echo gtester -k --verbose -o=$(XML_REPORT) ./test-loader >> loader-tester
@chmod +x loader-tester