aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-02-18 10:06:47 -0600
committerTed Gould <ted@gould.cx>2010-02-18 10:06:47 -0600
commitfa27dc5358b3a661f35427caab7b3a2dee4781bf (patch)
treea6fc4809273437fdf45ca5ad68528eef24666cda /tests/Makefile.am
parent8eee8911bad5fc290c6b8d9a3f71b94a633a2e2c (diff)
parent0fc874707a8d16fb5a23f3d23b281587b19cd17f (diff)
downloadlibayatana-indicator-fa27dc5358b3a661f35427caab7b3a2dee4781bf.tar.gz
libayatana-indicator-fa27dc5358b3a661f35427caab7b3a2dee4781bf.tar.bz2
libayatana-indicator-fa27dc5358b3a661f35427caab7b3a2dee4781bf.zip
* Upstream merge
* Adding new object for parsing desktop files for Shortcuts
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b111655..cd1a958 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -34,6 +34,42 @@ test_loader_LDADD = \
-lindicator
#############################
+# Test Desktop Shortcuts
+#############################
+
+check_PROGRAMS += test-desktop-shortcuts
+
+test_desktop_shortcuts_SOURCES = \
+ test-desktop-shortcuts.c
+
+test_desktop_shortcuts_CFLAGS = \
+ -Wall -Werror \
+ -DSRCDIR="\"$(srcdir)\"" \
+ $(LIBINDICATOR_CFLAGS) -I$(top_srcdir) \
+ -DBUILD_DIR="\"$(builddir)\""
+
+test_desktop_shortcuts_LDADD = \
+ $(LIBINDICATOR_LIBS) \
+ -L$(top_builddir)/libindicator/.libs \
+ -lindicator
+
+DS_XML_REPORT = desktop-shortcuts-check-results.xml
+DS_HTML_REPORT = desktop-shortcuts-check-results.html
+
+test-desktop-shortcuts-tester: test-desktop-shortcuts Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo $(XVFB_RUN) >> $@
+ @echo gtester -k --verbose -o=$(XML_REPORT) ./test-desktop-shortcuts >> $@
+ @chmod +x $@
+
+TESTS += test-desktop-shortcuts-tester
+DISTCLEANFILES += test-desktop-shortcuts-tester \
+ test-desktop-shortcuts-touch-test \
+ $(DS_XML_REPORT) \
+ $(DS_HTML_REPORT)
+EXTRA_DIST += test-well-formed.desktop
+
+#############################
# Dummy Indicator Blank
#############################