aboutsummaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-11-24 10:28:51 -0600
committerTed Gould <ted@gould.cx>2009-11-24 10:28:51 -0600
commitcc1c8d4e0b1112019318a0657e1134b113165d88 (patch)
tree5305797d97514b6acfe2d166a25c518ea07cb2d8 /tools/Makefile.am
parentf8b4671f30099da13044a0ab5513beef131ef15b (diff)
parentb6f78fa67858712e0345c233575104902be9e5dc (diff)
downloadlibayatana-indicator-cc1c8d4e0b1112019318a0657e1134b113165d88.tar.gz
libayatana-indicator-cc1c8d4e0b1112019318a0657e1134b113165d88.tar.bz2
libayatana-indicator-cc1c8d4e0b1112019318a0657e1134b113165d88.zip
Adding a new tool to load indicators from the command line.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 9de44fc..5e5ef8d 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1 +1,21 @@
-#Something
+
+libexec_PROGRAMS = \
+ indicator-loader
+
+#############################
+# Indicator Loader
+#############################
+
+indicator_loader_SOURCES = \
+ indicator-loader.c
+
+indicator_loader_CFLAGS = \
+ -Wall -Werror \
+ $(LIBINDICATOR_CFLAGS) -I$(top_srcdir) \
+ -DBUILD_DIR="\"$(builddir)\""
+
+indicator_loader_LDADD = \
+ $(LIBINDICATOR_LIBS) \
+ -L$(top_builddir)/libindicator/.libs \
+ -lindicator
+