aboutsummaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-11-24 16:35:04 -0600
committerTed Gould <ted@gould.cx>2009-11-24 16:35:04 -0600
commit5d0d185e805c993b96431c91f73bea369a6357cf (patch)
tree59214d4aa7120bd31c7e9917f0b5478554330af1 /tools/Makefile.am
parentf8b4671f30099da13044a0ab5513beef131ef15b (diff)
parent01c14391edf719e0cd7cc29d4153b878f8981e0e (diff)
downloadlibayatana-indicator-5d0d185e805c993b96431c91f73bea369a6357cf.tar.gz
libayatana-indicator-5d0d185e805c993b96431c91f73bea369a6357cf.tar.bz2
libayatana-indicator-5d0d185e805c993b96431c91f73bea369a6357cf.zip
* Adding a new tool to load indicators from the command line.
* debian/control, debian/libindicator-tools: Adding in a new package for the tools of libindicator.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 9de44fc..5e5ef8d 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1 +1,21 @@
-#Something
+
+libexec_PROGRAMS = \
+ indicator-loader
+
+#############################
+# Indicator Loader
+#############################
+
+indicator_loader_SOURCES = \
+ indicator-loader.c
+
+indicator_loader_CFLAGS = \
+ -Wall -Werror \
+ $(LIBINDICATOR_CFLAGS) -I$(top_srcdir) \
+ -DBUILD_DIR="\"$(builddir)\""
+
+indicator_loader_LDADD = \
+ $(LIBINDICATOR_LIBS) \
+ -L$(top_builddir)/libindicator/.libs \
+ -lindicator
+