aboutsummaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-01-13 12:43:15 -0600
committerTed Gould <ted@gould.cx>2011-01-13 12:43:15 -0600
commit22a9ca4cf025fed3bedd6aa12643cfe4cacfd524 (patch)
tree019d13f8a9b9b81c1cad246d55f71f5a58911c25 /tools/Makefile.am
parentdf21e797234f5bb4bd7e2a014296efe20ac6d2f3 (diff)
parentee32949d96d2c2243f4869c06d34d1d55031f411 (diff)
downloadlibayatana-indicator-22a9ca4cf025fed3bedd6aa12643cfe4cacfd524.tar.gz
libayatana-indicator-22a9ca4cf025fed3bedd6aa12643cfe4cacfd524.tar.bz2
libayatana-indicator-22a9ca4cf025fed3bedd6aa12643cfe4cacfd524.zip
Import upstream version 0.3.16
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 6c67491..287d34f 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,11 +1,13 @@
if USE_GTK3
INDICATOR_LIB = -lindicator3
+libexec_PROGRAMS = indicator-loader3
+VER=3
else
+VER=
INDICATOR_LIB = -lindicator
+libexec_PROGRAMS = indicator-loader
endif
-libexec_PROGRAMS = \
- indicator-loader
#############################
# Indicator Loader
@@ -24,6 +26,14 @@ indicator_loader_LDADD = \
-L$(top_builddir)/libindicator/.libs \
$(INDICATOR_LIB)
+# We duplicate these here because Automake won't let us use $(VER) on the left hand side.
+# Since we carefully use $(VER) in the right hand side above, we can assign the same values.
+# Only one version of the library is every compiled at the same time, so it is safe to reuse
+# the right hand sides like this.
+indicator_loader3_SOURCES = $(indicator_loader_SOURCES)
+indicator_loader3_CFLAGS = $(indicator_loader_CFLAGS)
+indicator_loader3_LDADD = $(indicator_loader_LDADD)
+
xsessiondir = $(sysconfdir)/X11/Xsession.d
xsession_DATA = 80indicator-debugging