aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3bd312e..807cad0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,13 +2,17 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
SUBDIRS = \
libindicator \
- tests \
tools
-tests: libindicator
-
tools: libindicator
+if WANT_TESTS
+SUBDIRS += \
+ tests
+
+tests: libindicator
+endif
+
DISTCHECK_CONFIGURE_FLAGS = --disable-deprecations
DISTCLEANFILES = \