aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 11 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 3ec1ed7..6668ff3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,7 +53,9 @@ PKG_CHECK_MODULES(LIBINDICATE, glib-2.0 >= $GLIB_REQUIRED_VERSION
AC_SUBST(LIBINDICATE_CFLAGS)
AC_SUBST(LIBINDICATE_LIBS)
+###########################
# GObject Introspection
+###########################
PKG_CHECK_MODULES(GOBJECT_INTROSPECTION, [gobject-introspection-1.0 >= 0.6])
@@ -70,6 +72,12 @@ TYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
AC_SUBST(TYPELIBDIR)
###########################
+# GTK Doc
+###########################
+
+GTK_DOC_CHECK([1.4])
+
+###########################
# Internationalization
###########################
@@ -90,20 +98,10 @@ libindicate/Makefile
libindicate/indicate.pc
tests/Makefile
data/Makefile
-data/icons/Makefile
-data/icons/16x16/Makefile
-data/icons/22x22/Makefile
-data/icons/24x24/Makefile
-data/icons/32x32/Makefile
-data/icons/48x48/Makefile
-data/icons/scalable/Makefile
-data/icons/16x16/panel/Makefile
-data/icons/22x22/panel/Makefile
-data/icons/24x24/panel/Makefile
-data/icons/32x32/panel/Makefile
-data/icons/48x48/panel/Makefile
-data/icons/scalable/panel/Makefile
po/Makefile.in
+docs/Makefile
+docs/reference/Makefile
+docs/reference/version.xml
])
###########################