aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt17
1 files changed, 0 insertions, 17 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 74b48e6..72a4f86 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -11,20 +11,3 @@ else()
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicator.pc.in" "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-0.${API_VERSION}.pc" @ONLY)
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-0.${API_VERSION}.pc" DESTINATION "${CMAKE_INSTALL_FULL_LIBDIR}/pkgconfig/")
endif()
-
-# ayatana-indicators.target (only required once, so let's do it with FLAVOUR_GTK3)
-
-if (FLAVOUR_GTK3)
-
- pkg_check_modules(SYSTEMD systemd)
-
- if (${SYSTEMD_FOUND})
- if (${SYSTEMD_VERSION} VERSION_LESS 247)
- set(SYSTEMD_USER_UNIT_DIR "${CMAKE_INSTALL_FULL_LIBDIR}/systemd/user")
- else()
- pkg_get_variable(SYSTEMD_USER_UNIT_DIR systemd systemd_user_unit_dir)
- endif()
- install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicators.target" DESTINATION "${SYSTEMD_USER_UNIT_DIR}")
- endif()
-
-endif()