aboutsummaryrefslogtreecommitdiff
path: root/libindicator/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libindicator/Makefile.am')
-rw-r--r--libindicator/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libindicator/Makefile.am b/libindicator/Makefile.am
index 5c70345..47a902a 100644
--- a/libindicator/Makefile.am
+++ b/libindicator/Makefile.am
@@ -104,11 +104,11 @@ DBUS_SPECS = \
gen-%.xml.h: %.xml
@echo "Building $@ from $<"
- @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $<)));" > $@
+ @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@
gen-%.xml.c: %.xml
@echo "Building $@ from $<"
- @echo "const char * _$(subst -,_,$(subst .,_,$(basename $<))) = " > $@
+ echo "const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<)))) = " > $@
@sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
@echo ";" >> $@