aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am74
1 files changed, 16 insertions, 58 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 862046e..9f1c6d3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,72 +1,30 @@
-libexec_PROGRAMS = \
- indicate-and-crash \
- indicate-alot \
- listen-and-print \
- im-client \
- show-hide-server
-
-indicate_and_crash_SOURCES = \
- indicate-and-crash.c
-
-indicate_and_crash_CFLAGS = \
- -I $(srcdir)/.. \
- $(LIBINDICATE_CFLAGS)
+TESTS = \
+ test_simple
-indicate_and_crash_LDADD = \
- ../libindicate/libindicate.la \
- $(LIBINDICATE_LIBS)
-
-indicate_alot_SOURCES = \
- indicate-alot.c
-
-indicate_alot_CFLAGS = \
- -I $(srcdir)/.. \
- $(LIBINDICATE_CFLAGS)
-
-indicate_alot_LDADD = \
- ../libindicate/libindicate.la \
- $(LIBINDICATE_LIBS)
-
-listen_and_print_SOURCES = \
- listen-and-print.c
-
-listen_and_print_CFLAGS = \
- -I $(srcdir)/.. \
- $(LIBINDICATE_CFLAGS)
+libexec_PROGRAMS = \
+ test-simple-client \
+ test-simple-server
-listen_and_print_LDADD = \
- ../libindicate/libindicate.la \
- $(LIBINDICATE_LIBS)
+test_simple: test-simple-client test-simple-server
-im_client_SOURCES = \
- im-client.c
+test_simple_client_SOURCES = \
+ test-simple-client.c
-im_client_CFLAGS = \
- -I $(srcdir)/.. \
- $(LIBINDICATE_CFLAGS)
+test_simple_client_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
-im_client_LDADD = \
+test_simple_client_LDADD = \
../libindicate/libindicate.la \
$(LIBINDICATE_LIBS)
-show_hide_server_SOURCES = \
- show-hide-server.c
+test_simple_server_SOURCES = \
+ test-simple-server.c
-show_hide_server_CFLAGS = \
- -I $(srcdir)/.. \
- $(LIBINDICATE_CFLAGS)
+test_simple_server_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
-show_hide_server_LDADD = \
+test_simple_server_LDADD = \
../libindicate/libindicate.la \
$(LIBINDICATE_LIBS)
-examplesdir = $(docdir)/examples/
-
-examples_DATA = \
- $(indicate_and_crash_SOURCES) \
- $(indicate_alot_SOURCES) \
- $(listen_and_print_SOURCES) \
- $(im_client_SOURCES)
-
-EXTRA_DIST = $(examples_DATA)