aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am25
1 files changed, 13 insertions, 12 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8f290f9..9f1c6d3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,29 +1,30 @@
-DBUS_RUNNER=/home/ted/Development/dbus-fun/dbus-test-runner --dbus-config /home/ted/Development/dbus-fun/session.conf
-
TESTS = \
test_simple
-test_simple: test_simple_c test_simple_s
- $(DBUS_RUNNER) --task ./test_simple_c --task-name Client --task ./test_simple_s --task-name Server
+libexec_PROGRAMS = \
+ test-simple-client \
+ test-simple-server
+
+test_simple: test-simple-client test-simple-server
-test_simple_c_SOURCES = \
- test-simple-c.c
+test_simple_client_SOURCES = \
+ test-simple-client.c
-test_simple_c_CFLAGS = \
+test_simple_client_CFLAGS = \
$(LIBINDICATE_CFLAGS) -I$(srcdir)/..
-test_simple_c_LDADD = \
+test_simple_client_LDADD = \
../libindicate/libindicate.la \
$(LIBINDICATE_LIBS)
-test_simple_s_SOURCES = \
- test-simple-s.c
+test_simple_server_SOURCES = \
+ test-simple-server.c
-test_simple_s_CFLAGS = \
+test_simple_server_CFLAGS = \
$(LIBINDICATE_CFLAGS) -I$(srcdir)/..
-test_simple_s_LDADD = \
+test_simple_server_LDADD = \
../libindicate/libindicate.la \
$(LIBINDICATE_LIBS)