aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am27
1 files changed, 26 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6117bee..7d72047 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,8 @@
TESTS = \
test_simple \
test_interests \
- test_interests_multi
+ test_interests_multi \
+ test_thousand_indicators
libexec_PROGRAMS = \
test-interests-client \
@@ -12,6 +13,8 @@ libexec_PROGRAMS = \
test-interests-server3 \
test-interests-server4 \
test-interests-server5 \
+ test-thousand-indicators-client \
+ test-thousand-indicators-server
test-simple-client \
test-simple-server
@@ -114,3 +117,25 @@ test_interests_server5_LDADD = \
../libindicate/libindicate.la \
$(LIBINDICATE_LIBS)
+test_thousand_indicators: test-thousand-indicators-client test-thousand-indicators-server
+
+test_thousand_indicators_client_SOURCES = \
+ test-thousand-indicators-client.c
+
+test_thousand_indicators_client_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_thousand_indicators_client_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+
+test_thousand_indicators_server_SOURCES = \
+ test-thousand-indicators-server.c
+
+test_thousand_indicators_server_CFLAGS = \
+ $(LIBINDICATE_CFLAGS) -I$(srcdir)/..
+
+test_thousand_indicators_server_LDADD = \
+ ../libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+