aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8ac6544..a04855c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1 +1,24 @@
-#Something should go here
+
+noinst_PROGRAMS = \
+ test-loader
+
+test_loader_SOURCES = \
+ test-loader.c
+
+test_loader_CFLAGS = \
+ -Wall -Werror \
+ $(UPANEL_CFLAGS) -I$(top_srcdir)
+
+test_loader_LDADD = \
+ $(UPANEL_LIBS) $(top_builddir)/libindicator/.libs/libindicator.a
+
+XML_REPORT = loader-check-results.xml
+HTML_REPORT = loader-check-results.html
+
+loader-tester: test-loader
+ @gtester -o=$(XML_REPORT) ./test-loader
+
+check-local: loader-tester
+
+DISTCLEANFILES = $(XML_REPORT) $(HTML_REPORT)
+