aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am470
1 files changed, 151 insertions, 319 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 69b9f26..177b4d8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,4 +1,3 @@
-
DBUS_RUNNER=dbus-test-runner --max-wait=0
CLEANFILES=
@@ -29,7 +28,12 @@ TESTS += \
test-gtk-label \
test-gtk-shortcut \
test-gtk-reorder \
- test-gtk-parser-test
+ test-gtk-remove
+# This is failing on Jenkins ARM but no where else that we
+# can get debug output. So we're going to disable it for now
+# as we have unity-gtk-module doing the majority of our GTK
+# menu parsing today.
+# test-gtk-parser-test
# Not working with GTK3 and a critical grab that is in
# the GTK3 code.
# test-gtk-submenu
@@ -81,6 +85,7 @@ check_PROGRAMS += \
test-gtk-label-server \
test-gtk-shortcut-client \
test-gtk-shortcut-server \
+ test-gtk-remove-server \
test-gtk-reorder-server \
test-gtk-submenu-server \
test-gtk-submenu-client \
@@ -92,6 +97,22 @@ XVFB_RUN=". $(srcdir)/run-xvfb.sh"
# for the GI tests, prefer/use the typelibs from the local build tree
TESTS_ENVIRONMENT = env GI_TYPELIB_PATH=$(top_builddir)/libdbusmenu-glib:$(top_builddir)/libdbusmenu-gtk:$(GI_TYPELIB_PATH)
+############################################
+# Shared vars for the dbusmenu-glib tests
+############################################
+
+DBUSMENU_GLIB_TEST_CFLAGS = \
+ -Wall -Werror \
+ -DG_DISABLE_DEPRECATED \
+ -I$(top_srcdir) \
+ $(DBUSMENUTESTS_CFLAGS) \
+ $(DBUSMENUGLIB_CFLAGS)
+
+DBUSMENU_GLIB_TEST_LDADD = \
+ $(top_builddir)/libdbusmenu-glib/libdbusmenu-glib.la \
+ $(DBUSMENUGLIB_LIBS) \
+ $(DBUSMENUTESTS_LIBS)
+
######################
# JSON Loader lib
######################
@@ -113,18 +134,11 @@ libdbusmenu_jsonloader_la_LDFLAGS = \
-export-symbols-regex "^[^_].*"
libdbusmenu_jsonloader_la_CFLAGS = \
- $(DBUSMENUGLIB_CFLAGS) \
- $(DBUSMENUTESTS_CFLAGS) \
- -I $(srcdir)/.. \
- -Wall \
- -Werror \
- -DG_DISABLE_DEPRECATED \
+ $(DBUSMENU_GLIB_TEST_CFLAGS) \
-DG_LOG_DOMAIN="\"LIBDBUSMENU-JSONLOADER\""
libdbusmenu_jsonloader_la_LIBADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS) \
- $(DBUSMENUTESTS_LIBS)
+ $(DBUSMENU_GLIB_TEST_LDADD)
pkgconfig_DATA = dbusmenu-jsonloader-0.4.pc
pkgconfigdir = $(libdir)/pkgconfig
@@ -133,16 +147,9 @@ pkgconfigdir = $(libdir)/pkgconfig
# Test GLib server
######################
-glib_server_nomenu_SOURCES = \
- glib-server-nomenu.c
-
-glib_server_nomenu_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-glib_server_nomenu_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
+glib_server_nomenu_SOURCES = glib-server-nomenu.c
+glib_server_nomenu_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+glib_server_nomenu_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
######################
# Test Glib Layout
@@ -152,32 +159,17 @@ test-glib-layout: test-glib-layout-client test-glib-layout-server Makefile.am
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(DBUS_RUNNER) --task ./test-glib-layout-client --task-name Client --task ./test-glib-layout-server --task-name Server --ignore-return >> $@
@chmod +x $@
-test_glib_layout_server_SOURCES = \
- test-glib-layout.h \
- test-glib-layout-server.c
+test_glib_layout_server_SOURCES = test-glib-layout.h test-glib-layout-server.c
+test_glib_layout_server_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_layout_server_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
-test_glib_layout_server_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_glib_layout_server_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
-
-test_glib_layout_client_SOURCES = \
- test-glib-layout.h \
- test-glib-layout-client.c
-
-test_glib_layout_client_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_glib_layout_client_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
+test_glib_layout_client_SOURCES = test-glib-layout.h test-glib-layout-client.c
+test_glib_layout_client_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_layout_client_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
######################
# Test Glib Events
@@ -187,30 +179,17 @@ test-glib-events: test-glib-events-client test-glib-events-server Makefile.am
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(DBUS_RUNNER) --task ./test-glib-events-client --task-name Client --task ./test-glib-events-server --task-name Server --ignore-return >> $@
@chmod +x $@
-test_glib_events_server_SOURCES = \
- test-glib-events-server.c
-
-test_glib_events_server_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_glib_events_server_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
-
-test_glib_events_client_SOURCES = \
- test-glib-events-client.c
+test_glib_events_server_SOURCES = test-glib-events-server.c
+test_glib_events_server_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_events_server_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
-test_glib_events_client_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_glib_events_client_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
+test_glib_events_client_SOURCES = test-glib-events-client.c
+test_glib_events_client_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_events_client_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
################################
# Test Glib Events No Grouping
@@ -220,19 +199,13 @@ test-glib-events-nogroup: test-glib-events-nogroup-client test-glib-events-serve
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(DBUS_RUNNER) --task ./test-glib-events-nogroup-client --task-name Client --task ./test-glib-events-server --task-name Server --ignore-return >> $@
@chmod +x $@
-test_glib_events_nogroup_client_SOURCES = \
- test-glib-events-nogroup-client.c
-
-test_glib_events_nogroup_client_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_glib_events_nogroup_client_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
+test_glib_events_nogroup_client_SOURCES = test-glib-events-nogroup-client.c
+test_glib_events_nogroup_client_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_events_nogroup_client_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
######################
# Test JSON
@@ -242,6 +215,7 @@ test-json: test-json-client test-json-server Makefile.am
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(XVFB_RUN) >> $@
@echo $(DBUS_RUNNER) --task ./test-json-client --wait-for org.dbusmenu.test --task-name Client --parameter $(top_builddir)/tools/dbusmenu-dumper --parameter test-json-01.output.json --task ./test-json-server --task-name Server --parameter $(srcdir)/test-json-01.json >> $@
@echo diff $(srcdir)/test-json-01.json test-json-01.output.json \> /dev/null >> $@
@@ -253,30 +227,17 @@ test_json_server_SOURCES = \
test-json-server.c
test_json_server_CFLAGS = \
- -I $(srcdir)/.. \
- -I $(srcdir) \
- $(DBUSMENUGLIB_CFLAGS) \
- $(DBUSMENUTESTS_CFLAGS) \
- $(DBUSMENUTESTSVALGRIND_CFLAGS) \
- -Wall -Werror
+ $(DBUSMENU_GLIB_TEST_CFLAGS) \
+ -I$(srcdir) \
+ $(DBUSMENUTESTSVALGRIND_CFLAGS)
test_json_server_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
libdbusmenu-jsonloader.la \
- $(DBUSMENUTESTS_LIBS) \
- $(DBUSMENUGLIB_LIBS)
+ $(DBUSMENU_GLIB_TEST_LDADD)
-test_json_client_SOURCES = \
- test-json-client.c
-
-test_json_client_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_json_client_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUTESTS_LIBS) \
- $(DBUSMENUGLIB_LIBS)
+test_json_client_SOURCES = test-json-client.c
+test_json_client_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_json_client_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
#########################
# Test JSON Instructions
@@ -286,6 +247,7 @@ test-json-instruction: test-json-client test-json-server test-json-instruction-c
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(XVFB_RUN) >> $@
@echo $(DBUS_RUNNER) --task $(builddir)/test-json-client --wait-for org.dbusmenu.test --task-name Client --parameter $(top_builddir)/tools/dbusmenu-dumper --parameter /dev/null --task libtool --parameter --mode=execute --parameter $(srcdir)/test-json-instruction-count --parameter $(builddir)/test-json-server --task-name Server --parameter $(srcdir)/test-json-01.json >> $@
@chmod +x $@
@@ -305,32 +267,17 @@ test-glib-submenu: test-glib-submenu-client test-glib-submenu-server Makefile.am
# in the grabbing code on GTK3. Since we can't add events to the stack
# we can't remove this error from getting thrown :-(
# @echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(DBUS_RUNNER) --task ./test-glib-submenu-client --task-name Client --task ./test-glib-submenu-server --task-name Server --ignore-return >> $@
@chmod +x $@
-test_glib_submenu_server_SOURCES = \
- test-glib-submenu.h \
- test-glib-submenu-server.c
-
-test_glib_submenu_server_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+test_glib_submenu_server_SOURCES = test-glib-submenu.h test-glib-submenu-server.c
+test_glib_submenu_server_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_submenu_server_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
-test_glib_submenu_server_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
-
-test_glib_submenu_client_SOURCES = \
- test-glib-submenu.h \
- test-glib-submenu-client.c
-
-test_glib_submenu_client_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_glib_submenu_client_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
+test_glib_submenu_client_SOURCES = test-glib-submenu.h test-glib-submenu-client.c
+test_glib_submenu_client_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_submenu_client_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
######################
# Test Glib Object
@@ -342,19 +289,13 @@ test-glib-objects-test: test-glib-objects Makefile.am
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(DBUS_RUNNER) --task gtester --task-name test --parameter --verbose --parameter -k --parameter -o --parameter $(OBJECT_XML_REPORT) --parameter ./test-glib-objects >> $@
@chmod +x $@
-test_glib_objects_SOURCES = \
- test-glib-objects.c
-
-test_glib_objects_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_glib_objects_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
+test_glib_objects_SOURCES = test-glib-objects.c
+test_glib_objects_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_objects_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
DISTCLEANFILES += $(OBJECT_XML_REPORT)
@@ -366,32 +307,17 @@ test-glib-properties: test-glib-properties-client test-glib-properties-server Ma
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(DBUS_RUNNER) --task ./test-glib-properties-client --task-name Client --task ./test-glib-properties-server --task-name Server --ignore-return >> $@
@chmod +x $@
-test_glib_properties_server_SOURCES = \
- test-glib-properties.h \
- test-glib-properties-server.c
-
-test_glib_properties_server_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_glib_properties_server_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
+test_glib_properties_server_SOURCES = test-glib-properties.h test-glib-properties-server.c
+test_glib_properties_server_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_properties_server_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
-test_glib_properties_client_SOURCES = \
- test-glib-properties.h \
- test-glib-properties-client.c
-
-test_glib_properties_client_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_glib_properties_client_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
+test_glib_properties_client_SOURCES = test-glib-properties.h test-glib-properties-client.c
+test_glib_properties_client_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_properties_client_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
######################
# Test Glib Proxy
@@ -401,6 +327,7 @@ test-glib-proxy: test-glib-proxy-client test-glib-proxy-server test-glib-proxy-p
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(DBUS_RUNNER) --task ./test-glib-proxy-client --task-name Client --task ./test-glib-proxy-server --task-name Server --ignore-return \\ >> $@
@echo --task ./test-glib-proxy-proxy --parameter test.proxy.first_proxy --parameter test.proxy.second_proxy --task-name Proxy01 --ignore-return \\ >> $@
@echo --task ./test-glib-proxy-proxy --parameter test.proxy.second_proxy --parameter test.proxy.third_proxy --task-name Proxy02 --ignore-return \\ >> $@
@@ -409,58 +336,40 @@ test-glib-proxy: test-glib-proxy-client test-glib-proxy-server test-glib-proxy-p
@echo --task ./test-glib-proxy-proxy --parameter test.proxy.last_proxy --parameter test.proxy.server --task-name Proxy05 --ignore-return >> $@
@chmod +x $@
-test_glib_proxy_server_SOURCES = \
- test-glib-proxy.h \
- test-glib-proxy-server.c
-
-test_glib_proxy_server_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_glib_proxy_server_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
-
-test_glib_proxy_client_SOURCES = \
- test-glib-proxy.h \
- test-glib-proxy-client.c
-
-test_glib_proxy_client_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_glib_proxy_client_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
+test_glib_proxy_server_SOURCES = test-glib-proxy.h test-glib-proxy-server.c
+test_glib_proxy_server_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_proxy_server_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
-test_glib_proxy_proxy_SOURCES = \
- test-glib-proxy.h \
- test-glib-proxy-proxy.c
+test_glib_proxy_client_SOURCES = test-glib-proxy.h test-glib-proxy-client.c
+test_glib_proxy_client_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_proxy_client_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
-test_glib_proxy_proxy_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_glib_proxy_proxy_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
+test_glib_proxy_proxy_SOURCES = test-glib-proxy.h test-glib-proxy-proxy.c
+test_glib_proxy_proxy_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_proxy_proxy_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
#########################
# Test Glib Simple Items
#########################
-test_glib_simple_items_SOURCES = \
- test-glib-simple-items.c
+test_glib_simple_items_SOURCES = test-glib-simple-items.c
+test_glib_simple_items_CFLAGS = $(DBUSMENU_GLIB_TEST_CFLAGS)
+test_glib_simple_items_LDADD = $(DBUSMENU_GLIB_TEST_LDADD)
-test_glib_simple_items_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+EXTRA_DIST += test-glib-simple-items.py
-test_glib_simple_items_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- $(DBUSMENUGLIB_LIBS)
+############################################
+# Shared vars for the dbusmenu-gtk tests
+############################################
-EXTRA_DIST += test-glib-simple-items.py
+DBUSMENU_GTK_TEST_CFLAGS = \
+ $(DBUSMENUGTK_CFLAGS) \
+ $(DBUSMENU_GLIB_TEST_CFLAGS)
+
+DBUSMENU_GTK_TEST_LDADD = \
+ $(top_builddir)/libdbusmenu-gtk/libdbusmenu-gtk$(VER).la \
+ $(DBUSMENUGTK_LIBS) \
+ $(DBUSMENU_GLIB_TEST_LDADD)
######################
# Test GTK Object
@@ -472,25 +381,14 @@ test-gtk-objects-test: test-gtk-objects Makefile.am
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(XVFB_RUN) >> $@
@echo $(DBUS_RUNNER) --task gtester --task-name test --parameter --verbose --parameter -k --parameter -o --parameter $(GTK_OBJECT_XML_REPORT) --parameter ./test-gtk-objects >> $@
@chmod +x $@
-test_gtk_objects_SOURCES = \
- test-gtk-objects.c
-
-test_gtk_objects_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) \
- $(DBUSMENUGTK_CFLAGS) \
- -DSRCDIR="\"$(srcdir)\"" \
- -Wall -Werror
-
-test_gtk_objects_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- ../libdbusmenu-gtk/libdbusmenu-gtk$(VER).la \
- $(DBUSMENUGLIB_LIBS) \
- $(DBUSMENUGTK_LIBS)
+test_gtk_objects_SOURCES = test-gtk-objects.c
+test_gtk_objects_CFLAGS = $(DBUSMENU_GTK_TEST_CFLAGS) -DSRCDIR="\"$(srcdir)\""
+test_gtk_objects_LDADD = $(DBUSMENU_GTK_TEST_LDADD)
DISTCLEANFILES += $(GTK_OBJECT_XML_REPORT)
@@ -504,25 +402,14 @@ test-gtk-parser-test: test-gtk-parser Makefile.am
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(XVFB_RUN) >> $@
- @echo gtester --verbose -k -o $(GTK_PARSER_XML_REPORT) ./test-gtk-parser >> $@
+ @echo $(DBUS_RUNNER) --task gtester --task-name test --parameter --verbose --parameter -k --parameter -o --parameter $(GTK_PARSER_XML_REPORT) --parameter $(builddir)/test-gtk-parser >> $@
@chmod +x $@
-test_gtk_parser_SOURCES = \
- test-gtk-parser.c
-
-test_gtk_parser_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGLIB_CFLAGS) \
- $(DBUSMENUGTK_CFLAGS) \
- -DSRCDIR="\"$(srcdir)\"" \
- -Wall -Werror
-
-test_gtk_parser_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- ../libdbusmenu-gtk/libdbusmenu-gtk$(VER).la \
- $(DBUSMENUGLIB_LIBS) \
- $(DBUSMENUGTK_LIBS)
+test_gtk_parser_SOURCES = test-gtk-parser.c
+test_gtk_parser_CFLAGS = $(DBUSMENU_GTK_TEST_CFLAGS) -DSRCDIR="\"$(srcdir)\""
+test_gtk_parser_LDADD = $(DBUSMENU_GTK_TEST_LDADD)
DISTCLEANFILES += $(GTK_PARSER_XML_REPORT)
@@ -534,40 +421,18 @@ test-gtk-label: test-gtk-label-client test-gtk-label-server test-gtk-label.json
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(XVFB_RUN) >> $@
@echo $(DBUS_RUNNER) --task ./test-gtk-label-client --task-name Client --task ./test-gtk-label-server --parameter $(srcdir)/test-gtk-label.json --task-name Server --ignore-return >> $@
@chmod +x $@
-test_gtk_label_server_SOURCES = \
- test-gtk-label-server.c
-
-test_gtk_label_server_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGTK_CFLAGS) \
- $(DBUSMENUTESTS_CFLAGS) \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_gtk_label_server_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- ../libdbusmenu-gtk/libdbusmenu-gtk$(VER).la \
- libdbusmenu-jsonloader.la \
- $(DBUSMENUGTK_LIBS) \
- $(DBUSMENUTESTS_LIBS)
-
-test_gtk_label_client_SOURCES = \
- test-gtk-label-client.c
+test_gtk_label_server_SOURCES = test-gtk-label-server.c
+test_gtk_label_server_CFLAGS = $(DBUSMENU_GTK_TEST_CFLAGS)
+test_gtk_label_server_LDADD = libdbusmenu-jsonloader.la $(DBUSMENU_GTK_TEST_LDADD)
-test_gtk_label_client_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGTK_CFLAGS) \
- $(DBUSMENUTESTS_CFLAGS) \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_gtk_label_client_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- ../libdbusmenu-gtk/libdbusmenu-gtk$(VER).la \
- $(DBUSMENUGTK_LIBS) \
- $(DBUSMENUTESTS_LIBS)
+test_gtk_label_client_SOURCES = test-gtk-label-client.c
+test_gtk_label_client_CFLAGS = $(DBUSMENU_GTK_TEST_CFLAGS)
+test_gtk_label_client_LDADD = $(DBUSMENU_GTK_TEST_LDADD)
#########################
# Test GTK Shortcut
@@ -577,39 +442,18 @@ test-gtk-shortcut: test-gtk-shortcut-client test-gtk-shortcut-server Makefile.am
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(XVFB_RUN) >> $@
@echo $(DBUS_RUNNER) --task ./test-gtk-shortcut-client --task-name Client --task ./test-gtk-shortcut-server --task-name Server --ignore-return >> $@
@chmod +x $@
-test_gtk_shortcut_server_SOURCES = \
- test-gtk-shortcut-server.c
+test_gtk_shortcut_server_SOURCES = test-gtk-shortcut-server.c
+test_gtk_shortcut_server_CFLAGS = $(DBUSMENU_GTK_TEST_CFLAGS)
+test_gtk_shortcut_server_LDADD = $(DBUSMENU_GTK_TEST_LDADD)
-test_gtk_shortcut_server_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGTK_CFLAGS) \
- $(DBUSMENUTESTS_CFLAGS) \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_gtk_shortcut_server_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- ../libdbusmenu-gtk/libdbusmenu-gtk$(VER).la \
- $(DBUSMENUGTK_LIBS) \
- $(DBUSMENUTESTS_LIBS)
-
-test_gtk_shortcut_client_SOURCES = \
- test-gtk-shortcut-client.c
-
-test_gtk_shortcut_client_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGTK_CFLAGS) \
- $(DBUSMENUTESTS_CFLAGS) \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_gtk_shortcut_client_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- ../libdbusmenu-gtk/libdbusmenu-gtk$(VER).la \
- $(DBUSMENUGTK_LIBS) \
- $(DBUSMENUTESTS_LIBS)
+test_gtk_shortcut_client_SOURCES = test-gtk-shortcut-client.c
+test_gtk_shortcut_client_CFLAGS = $(DBUSMENU_GTK_TEST_CFLAGS)
+test_gtk_shortcut_client_LDADD = $(DBUSMENU_GTK_TEST_LDADD)
#########################
# Test GTK Shortcut Python
@@ -619,6 +463,7 @@ test-gtk-shortcut-python: test-gtk-shortcut-server test-gtk-shortcut-client.py M
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(XVFB_RUN) >> $@
@echo $(DBUS_RUNNER) --task $(srcdir)/test-gtk-shortcut-client.py --task-name Client --task ./test-gtk-shortcut-server --task-name Server --ignore-return >> $@
@chmod +x $@
@@ -627,6 +472,23 @@ EXTRA_DIST += test-gtk-shortcut-client.py
CLEANFILES += test-gtk-shortcut-client.pyc
#########################
+# Test GTK Remove
+#########################
+
+test-gtk-remove: test-gtk-remove-server Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo export UBUNTU_MENUPROXY="" >> $@
+ @echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
+ @echo $(XVFB_RUN) >> $@
+ @echo $(DBUS_RUNNER) --task ./test-gtk-remove-server --parameter $(srcdir)/test-gtk-label.json --task-name Server --ignore-return >> $@
+ @chmod +x $@
+
+test_gtk_remove_server_SOURCES = test-gtk-remove-server.c
+test_gtk_remove_server_CFLAGS = $(DBUSMENU_GTK_TEST_CFLAGS)
+test_gtk_remove_server_LDADD = $(DBUSMENU_GTK_TEST_LDADD)
+
+#########################
# Test GTK Reorder
#########################
@@ -634,24 +496,14 @@ test-gtk-reorder: test-gtk-label-client test-gtk-reorder-server Makefile.am
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(XVFB_RUN) >> $@
@echo $(DBUS_RUNNER) --task ./test-gtk-label-client --task-name Client --task ./test-gtk-reorder-server --parameter $(srcdir)/test-gtk-label.json --task-name Server --ignore-return >> $@
@chmod +x $@
-test_gtk_reorder_server_SOURCES = \
- test-gtk-reorder-server.c
-
-test_gtk_reorder_server_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGTK_CFLAGS) \
- $(DBUSMENUTESTS_CFLAGS) \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_gtk_reorder_server_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- ../libdbusmenu-gtk/libdbusmenu-gtk$(VER).la \
- $(DBUSMENUGTK_LIBS) \
- $(DBUSMENUTESTS_LIBS)
+test_gtk_reorder_server_SOURCES = test-gtk-reorder-server.c
+test_gtk_reorder_server_CFLAGS = $(DBUSMENU_GTK_TEST_CFLAGS)
+test_gtk_reorder_server_LDADD = $(DBUSMENU_GTK_TEST_LDADD)
#########################
# Test GTK Submenu
@@ -661,39 +513,18 @@ test-gtk-submenu: test-gtk-submenu-client test-gtk-submenu-server Makefile.am
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(XVFB_RUN) >> $@
@echo $(DBUS_RUNNER) --task ./test-gtk-submenu-client --task-name Client --task ./test-gtk-submenu-server --task-name Server --ignore-return >> $@
@chmod +x $@
-test_gtk_submenu_server_SOURCES = \
- test-gtk-submenu-server.c
-
-test_gtk_submenu_server_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGTK_CFLAGS) \
- $(DBUSMENUTESTS_CFLAGS) \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_gtk_submenu_server_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- ../libdbusmenu-gtk/libdbusmenu-gtk$(VER).la \
- $(DBUSMENUGTK_LIBS) \
- $(DBUSMENUTESTS_LIBS)
+test_gtk_submenu_server_SOURCES = test-gtk-submenu-server.c
+test_gtk_submenu_server_CFLAGS = $(DBUSMENU_GTK_TEST_CFLAGS)
+test_gtk_submenu_server_LDADD = $(DBUSMENU_GTK_TEST_LDADD)
-test_gtk_submenu_client_SOURCES = \
- test-gtk-submenu-client.c
-
-test_gtk_submenu_client_CFLAGS = \
- -I $(srcdir)/.. \
- $(DBUSMENUGTK_CFLAGS) \
- $(DBUSMENUTESTS_CFLAGS) \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
-
-test_gtk_submenu_client_LDADD = \
- ../libdbusmenu-glib/libdbusmenu-glib.la \
- ../libdbusmenu-gtk/libdbusmenu-gtk$(VER).la \
- $(DBUSMENUGTK_LIBS) \
- $(DBUSMENUTESTS_LIBS)
+test_gtk_submenu_client_SOURCES = test-gtk-submenu-client.c
+test_gtk_submenu_client_CFLAGS = $(DBUSMENU_GTK_TEST_CFLAGS)
+test_gtk_submenu_client_LDADD = $(DBUSMENU_GTK_TEST_LDADD)
#########################
# Test Mago
@@ -703,6 +534,7 @@ test-mago: test-gtk-label-client test-gtk-label-server $(srcdir)/dbusmenu-gtk/ma
@echo "#!/bin/bash" > $@
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
+ @echo export G_MESSAGES_DEBUG=all >> $@
@echo $(XVFB_RUN) >> $@
@echo cd $(srcdir)/dbusmenu-gtk >> $@
@echo /usr/lib/at-spi/at-spi-registryd \& >> $@