aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-08-17 11:24:12 -0500
committerTed Gould <ted@gould.cx>2012-08-17 11:24:12 -0500
commit6b8fc6c1845aa0df788c37d997a7e11a7fdabba9 (patch)
treeb8b4933b2d690b439ba7c3d1b09763b0578c2ce5 /Makefile.am
downloadlibpam-x2go-6b8fc6c1845aa0df788c37d997a7e11a7fdabba9.tar.gz
libpam-x2go-6b8fc6c1845aa0df788c37d997a7e11a7fdabba9.tar.bz2
libpam-x2go-6b8fc6c1845aa0df788c37d997a7e11a7fdabba9.zip
Basic build system
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..769ade8
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,32 @@
+
+SUBDIRS = \
+ src
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
+
+dist-hook:
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || (rm -f ChangeLog.tmp; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo Failed to generate ChangeLog: not a branch >&2; \
+ fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi
+