aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-08-17 11:27:09 -0500
committerTed Gould <ted@gould.cx>2012-08-17 11:27:09 -0500
commit497c3e3ff6b0055e40fa5fad3db248a48902f40a (patch)
tree052bb27f25aecb33206f5bc42b946e283deef2b0 /configure.ac
parent6b8fc6c1845aa0df788c37d997a7e11a7fdabba9 (diff)
downloadlibpam-x2go-497c3e3ff6b0055e40fa5fad3db248a48902f40a.tar.gz
libpam-x2go-497c3e3ff6b0055e40fa5fad3db248a48902f40a.tar.bz2
libpam-x2go-497c3e3ff6b0055e40fa5fad3db248a48902f40a.zip
Adding a local directory option and setting the PAM install directory based on whether we're local or not
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 05b48d1..1d3a0a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,12 +7,38 @@ AM_SILENT_RULES([yes])
AC_PROG_CC
AC_PROG_LIBTOOL
+###########################
+# PAM
+###########################
+
have_pam=no
AC_CHECK_LIB(pam, pam_getenv, have_pam=yes)
if test "x$have_pam" = "xno"; then
AC_MSG_ERROR([Required library PAM was not found])
fi
+###########################
+# Local Install
+###########################
+
+with_localinstall="no"
+AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall],
+ [install all files locally (for distcheck)]),
+ with_localinstall=$enableval,
+ with_localinstall=no)
+
+###########################
+# PAM Module dir
+###########################
+
+if test "x$with_localinstall" = "xyes"; then
+ PAMMODULEDIR="${libdir}/security/"
+else
+ PAMMODULEDIR="/lib/security"
+fi
+AC_SUBST(PAMMODULEDIR)
+
+
AC_CONFIG_FILES([
Makefile
src/Makefile