aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-08-17 11:24:12 -0500
committerTed Gould <ted@gould.cx>2012-08-17 11:24:12 -0500
commit6b8fc6c1845aa0df788c37d997a7e11a7fdabba9 (patch)
treeb8b4933b2d690b439ba7c3d1b09763b0578c2ce5 /configure.ac
downloadlibpam-x2go-6b8fc6c1845aa0df788c37d997a7e11a7fdabba9.tar.gz
libpam-x2go-6b8fc6c1845aa0df788c37d997a7e11a7fdabba9.tar.bz2
libpam-x2go-6b8fc6c1845aa0df788c37d997a7e11a7fdabba9.zip
Basic build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..05b48d1
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,20 @@
+AC_INIT([pam-freerdp], [0.0.1])
+AC_CONFIG_HEADERS([config.h])
+
+AM_INIT_AUTOMAKE([1.11 -Wno-portability])
+AM_SILENT_RULES([yes])
+
+AC_PROG_CC
+AC_PROG_LIBTOOL
+
+have_pam=no
+AC_CHECK_LIB(pam, pam_getenv, have_pam=yes)
+if test "x$have_pam" = "xno"; then
+ AC_MSG_ERROR([Required library PAM was not found])
+fi
+
+AC_CONFIG_FILES([
+ Makefile
+ src/Makefile
+])
+AC_OUTPUT