aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-09-19 15:24:10 -0500
committerTed Gould <ted@gould.cx>2012-09-19 15:24:10 -0500
commit6f64adfc81105b9e76c3df530ebf6a5f401f7899 (patch)
tree78872f61aadc6e9d702f8e735764d0e7b2259496 /configure.ac
parente552688b70889a4879ef16ce38bc8c95e6f447c7 (diff)
downloadlibpam-x2go-6f64adfc81105b9e76c3df530ebf6a5f401f7899.tar.gz
libpam-x2go-6f64adfc81105b9e76c3df530ebf6a5f401f7899.tar.bz2
libpam-x2go-6f64adfc81105b9e76c3df530ebf6a5f401f7899.zip
Adding in Google test and Coverage build stuff
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a83d9bf..cee665d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,6 +5,8 @@ AM_INIT_AUTOMAKE([1.11 -Wno-portability])
AM_SILENT_RULES([yes])
AC_PROG_CC
+# the Google Test targets are cpp
+AC_PROG_CXX
AC_PROG_LIBTOOL
LT_INIT([disable-static])
@@ -46,6 +48,30 @@ else
fi
AC_SUBST(PAMMODULEDIR)
+###########################
+# Google Test Dependencies
+###########################
+
+m4_include([m4/gtest.m4])
+CHECK_GTEST
+if test "x$have_gtest" != "xyes"; then
+ AC_MSG_ERROR([tests were requested but gtest is not installed.])
+fi
+
+###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AM_CONDITIONAL([HAVE_GCOV], [test "x$ac_cv_check_gcov" = xyes])
+AM_CONDITIONAL([HAVE_LCOV], [test "x$ac_cv_check_lcov" = xyes])
+AM_CONDITIONAL([HAVE_GCOVR], [test "x$ac_cv_check_gcovr" = xyes])
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+
AC_CONFIG_FILES([
Makefile