summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-09-08 21:19:38 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-09-08 22:53:08 +0200
commit9b5d2bf6d6656acc06d5aab189515401530b5d02 (patch)
tree33706c0483ec7126b94518a21c61e19f7533894b /configure.ac
parentd087cb3dfb5be4094fbb017376873cac77265760 (diff)
downloadlibrda-9b5d2bf6d6656acc06d5aab189515401530b5d02.tar.gz
librda-9b5d2bf6d6656acc06d5aab189515401530b5d02.tar.bz2
librda-9b5d2bf6d6656acc06d5aab189515401530b5d02.zip
configure.ac et al.: Make it possible to enable/disable awareness for the supported remote desktop technologies at build time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index baad8eb..6f6f2c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,26 @@ dnl pkg-config dependency checks
PKG_CHECK_MODULES(LIBRDA, glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GIO_REQUIRED)
+dnl enable/disable awarenesses
+
+AC_ARG_ENABLE([x2go],
+ [AS_HELP_STRING([--enable-x2go],
+ [enable awareness of X2Go sessions])],
+ [enable_x2go=yes],
+ [enable_x2go=no])
+if test "x$enable_x2go" != "x"; then
+ AC_DEFINE([WITH_X2GO_AWARENESS],,[Build with X2Go awareness])
+fi
+
+AC_ARG_ENABLE([ogon],
+ [AS_HELP_STRING([--enable-ogon],
+ [enable awareness of Ogon sessions])],
+ [enable_ogon=yes],
+ [enable_ogon=no])
+if test "x$enable_ogon" != "x"; then
+ AC_DEFINE([WITH_OGON_AWARENESS],,[Build with Ogon awareness])
+fi
+
dnl Language Support
IT_PROG_INTLTOOL([0.50.1])
@@ -109,4 +129,7 @@ librda $VERSION
Use *_DISABLE_DEPRECATED: ${enable_deprecation_flags}
Build introspection support: ${found_introspection}
+
+ Enable X2Go awareness ${enable_x2go}
+ Enable Ogon awareness ${enable_ogon}
"