aboutsummaryrefslogtreecommitdiff
path: root/debian/Makefile.nx-libs
diff options
context:
space:
mode:
authorMihai Moldovan <ionic@ionic.de>2015-04-29 13:47:40 +0200
committerMihai Moldovan <ionic@ionic.de>2015-04-29 13:47:40 +0200
commit79d49066c11463b62f6ebc3fadf5e7de48f766db (patch)
treedb2e18fff0b85e18b7ac862ce06ca5989e40cf31 /debian/Makefile.nx-libs
parent266d5affbc8339411090db497bfbafdc5e4944b2 (diff)
downloadnx-libs-79d49066c11463b62f6ebc3fadf5e7de48f766db.tar.gz
nx-libs-79d49066c11463b62f6ebc3fadf5e7de48f766db.tar.bz2
nx-libs-79d49066c11463b62f6ebc3fadf5e7de48f766db.zip
libnx-xinerama1: also create libXinerama symlink in libnx-xinerama1.postinst.postinst (and remove in libnx-xinerama1.postinst.prerm.)
Due to the nx-x11-common package being a noarch/allarch package, creating the symlink in nx-libs' Makefile will lead to the symlink referencing the "default" architecture dpkg uses for building noarch/allarch packages. Incidentally, this worked fine for Debian, as amd64 seems to be the default architecture. On Ubuntu, however, the default architecture up to Vivid (15.04) was i386. For those builds, the symlink pointed to the 32 bit library of libNX_Xinerama.so.1 -- essentially breaking this feature. Move the symlink creation to the arch-sensitive libnx-xinerama1 package. The postinst and prerm scriptlets will work fine, unless someone installs the i386 package version *after* the amd64 version. Given that we already create symlinks to libNX_X11 and friends using that method, no new regression is introduced. Strictly speaking that's a bug, but we'll hopefully clean that up later...
Diffstat (limited to 'debian/Makefile.nx-libs')
-rw-r--r--debian/Makefile.nx-libs11
1 files changed, 6 insertions, 5 deletions
diff --git a/debian/Makefile.nx-libs b/debian/Makefile.nx-libs
index f0c8a978b..9df219e10 100644
--- a/debian/Makefile.nx-libs
+++ b/debian/Makefile.nx-libs
@@ -134,11 +134,12 @@ install-full:
done; \
# Provide means for Xinerama support in NX/X2Go sessions. This
- # This also requires two post-install symlinks:
- # (DESTDIR)$(NXLIBDIR)/X11/Xinerama/libNX_X11.so.6 -> /usr/<libdir>/libX11.so.6
- # (DESTDIR)$(NXLIBDIR)/X11/Xinerama/libNX_Xext.so.6 -> /usr/<libdir>/libXext.so.6
- $(INSTALL_DIR) $(DESTDIR)$(NXLIBDIR)/X11/Xinerama
- $(INSTALL_SYMLINK) $(USRLIBDIR)/libNX_Xinerama.so.1 $(DESTDIR)$(NXLIBDIR)/X11/Xinerama/libXinerama.so.1
+ # This also requires three post-install symlinks created by libnx-xinerama1:
+ # $(DESTDIR)$(NXLIBDIR)/X11/Xinerama/libNX_X11.so.6 -> /usr/<libdir>/libX11.so.6
+ # $(DESTDIR)$(NXLIBDIR)/X11/Xinerama/libNX_Xext.so.6 -> /usr/<libdir>/libXext.so.6
+ # $(DESTDIR)$(NXLIBDIR)/X11/Xinerama/libXinerama.so.1 -> /usr/<libdir>/libNX_Xinerama.so.1
+ # Only create the owned directory here for nx-x11-common.
+ $(INSTALL_DIR) $(DESTDIR)$(NXLIBDIR)/X11
$(INSTALL_DIR) $(DESTDIR)$(INCLUDEDIR)/nx/X11/bitmaps
$(INSTALL_FILE) nx-X11/.build-exports/include/X11/bitmaps/* \