aboutsummaryrefslogtreecommitdiff
path: root/debian/Makefile.nx-libs
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2012-12-12 12:45:41 +0100
committerReinhard Tartler <siretart@tauware.de>2012-12-12 17:08:32 +0100
commitd139e5d3da1b56457d7f076581de7e186fe2e6f2 (patch)
treefa65afe052c86b55bd43d092cd092c21f034a5b7 /debian/Makefile.nx-libs
parenta12ad50503536fc1e9cd3ff1bf11ef4869da6e6d (diff)
downloadnx-libs-d139e5d3da1b56457d7f076581de7e186fe2e6f2.tar.gz
nx-libs-d139e5d3da1b56457d7f076581de7e186fe2e6f2.tar.bz2
nx-libs-d139e5d3da1b56457d7f076581de7e186fe2e6f2.zip
drop debian/patches/001_add-main-makefile.full+lite.patch
Instead, place the makefile into debian/Makefile.nx-libs. This makes the makefile easier to edit.
Diffstat (limited to 'debian/Makefile.nx-libs')
-rw-r--r--debian/Makefile.nx-libs51
1 files changed, 51 insertions, 0 deletions
diff --git a/debian/Makefile.nx-libs b/debian/Makefile.nx-libs
new file mode 100644
index 000000000..3151be283
--- /dev/null
+++ b/debian/Makefile.nx-libs
@@ -0,0 +1,51 @@
+#!/usr/bin/make -f
+
+PREFIX ?= /usr/local
+CONFIGURE=./configure
+
+%:
+ if test -f bin/Makefile; then ${MAKE} -C bin $@; fi
+ if test -f nxcomp/Makefile; then ${MAKE} -C nxcomp $@; fi
+ if test -f nxproxy/Makefile; then ${MAKE} -C nxproxy $@; fi
+ if test -d nx-X11; then \
+ if test -f nxcompext/Makefile; then ${MAKE} -C nxcompext $@; fi; \
+ if test -f nxcompshad/Makefile; then ${MAKE} -C nxcompshad $@; fi; \
+ if test -f nx-X11/Makefile; then ${MAKE} -C nx-X11 $@; fi; \
+ fi
+
+all: build
+
+test:
+ echo "No testing for NX (redistributed)"
+
+build-lite:
+ cd nxcomp && autoconf && (${CONFIGURE}) && ${MAKE}
+ cd nxproxy && autoconf && (${CONFIGURE}) && ${MAKE}
+
+build-full:
+# in the full case, we rely on "magic" in the nx-X11 imake-based makefiles...
+ cd nxcomp && autoconf
+ cd nxcompext && autoconf
+ cd nxcompshad && autoconf
+ cd nx-X11 && ${MAKE} World
+ cd nxproxy && autoconf && (${CONFIGURE}) && ${MAKE}
+
+build:
+ if ! test -d nx-X11; then \
+ ${MAKE} build-lite; \
+ else \
+ ${MAKE} build-full; \
+ fi
+
+uninstall:
+ if test -f bin/Makefile; then ${MAKE} -C bin $@; fi
+ if test -f nxcomp/Makefile; then ${MAKE} -C nxcomp $@; fi
+ if test -f nxproxy/Makefile; then ${MAKE} -C nxproxy $@; fi
+ if test -d nx-X11; then \
+ if test -f nxcompext/Makefile; then ${MAKE} -C nxcompext $@; fi; \
+ if test -f nxcompshad/Makefile; then ${MAKE} -C nxcompshad $@; fi; \
+ if test -f nx-X11/Makefile; then \
+ if test -d $(PREFIX)/lib/nx; then rm -rf $(PREFIX)/lib/nx; fi; \
+ if test -d $(PREFIX)/include/nx; then rm -rf $(PREFIX)/include/nx; fi; \
+ fi; \
+ fi