aboutsummaryrefslogtreecommitdiff
path: root/debian/Makefile.nx-libs
diff options
context:
space:
mode:
authorMihai Moldovan <ionic@ionic.de>2017-10-16 10:04:54 +0200
committerMihai Moldovan <ionic@ionic.de>2017-10-16 10:04:54 +0200
commit13aed2463c7f10e238af86227c2d999b9fa620f2 (patch)
treeb7c621c15569f4da59904d7c545c43d6b28c48fc /debian/Makefile.nx-libs
parent9d750c686a3ce6d457041cdf5991a1a0749a8d0c (diff)
downloadnx-libs-13aed2463c7f10e238af86227c2d999b9fa620f2.tar.gz
nx-libs-13aed2463c7f10e238af86227c2d999b9fa620f2.tar.bz2
nx-libs-13aed2463c7f10e238af86227c2d999b9fa620f2.zip
OPTFLAGS: Properly propagate build option flags to nxcomp{,ext,shad} and the nx-X11 build scripts.
Backported from Arctica GH 3.6.x branch. v2: backport to nx-libs 3.5.0.x (Mihai Moldovan) Adds: - debian/patches/1500_all_propagate-optflags-to-subcompone.full+lite.patch
Diffstat (limited to 'debian/Makefile.nx-libs')
-rw-r--r--debian/Makefile.nx-libs15
1 files changed, 12 insertions, 3 deletions
diff --git a/debian/Makefile.nx-libs b/debian/Makefile.nx-libs
index 45ea8a958..884787742 100644
--- a/debian/Makefile.nx-libs
+++ b/debian/Makefile.nx-libs
@@ -42,9 +42,18 @@ build-lite:
build-full:
# in the full case, we rely on "magic" in the nx-X11 imake-based makefiles...
- cd nxcomp && autoconf
- cd nxcompext && autoconf
- cd nxcompshad && autoconf
+ cd nxcomp && autoconf && (${CONFIGURE}) && ${MAKE}
+
+ # prepare Makefiles and the nx-X11 symlinking magic
+ cd nx-X11 && make BuildEnv
+
+ # build libNX_X11 and libNX_Xext prior to building
+ # nxcomp{ext,shad}.
+ cd nx-X11/lib && make
+
+ cd nxcompext && autoconf && (${CONFIGURE}) && ${MAKE}
+ cd nxcompshad && autoconf && (${CONFIGURE}) && ${MAKE}
+
cd nx-X11 && ${MAKE} World
cd nxproxy && autoconf && (${CONFIGURE}) && ${MAKE}