aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/0611_nxcompshad_use-MAKEDEPEND-in-path.full.patch
diff options
context:
space:
mode:
authorX2Go Release Manager <git-admin@x2go.org>2015-03-17 19:09:05 +0100
committerX2Go Release Manager <git-admin@x2go.org>2015-03-17 19:11:33 +0100
commit71589a05045ef70d5f057e3ad29a62ca0b4c989d (patch)
treea36a47afcb31b802c15948ffba973617a3cdb624 /debian/patches/0611_nxcompshad_use-MAKEDEPEND-in-path.full.patch
parent8963b8e7099258a74ba85f8d4325fe6df5db1eae (diff)
downloadnx-libs-71589a05045ef70d5f057e3ad29a62ca0b4c989d.tar.gz
nx-libs-71589a05045ef70d5f057e3ad29a62ca0b4c989d.tar.bz2
nx-libs-71589a05045ef70d5f057e3ad29a62ca0b4c989d.zip
Mid-release fixup: Rename *nxcomp{ext,shad}*.full+lite* to *nxcomp{ext,shad}*.full*.redist-server/3.5.0.31redist-client/3.5.0.31
Diffstat (limited to 'debian/patches/0611_nxcompshad_use-MAKEDEPEND-in-path.full.patch')
-rw-r--r--debian/patches/0611_nxcompshad_use-MAKEDEPEND-in-path.full.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/debian/patches/0611_nxcompshad_use-MAKEDEPEND-in-path.full.patch b/debian/patches/0611_nxcompshad_use-MAKEDEPEND-in-path.full.patch
new file mode 100644
index 000000000..329a48937
--- /dev/null
+++ b/debian/patches/0611_nxcompshad_use-MAKEDEPEND-in-path.full.patch
@@ -0,0 +1,47 @@
+Description: Discover makedepend in $PATH. Especially important for MacPorts (OS X.)
+Author: Clemens Lang <cal@macports.org>
+ v2: Mihai Moldovan <ionic@ionic.de>
+
+--- a/nxcompshad/configure.in
++++ b/nxcompshad/configure.in
+@@ -269,18 +269,15 @@ fi
+ dnl Find makedepend somewhere.
+
+ AC_SUBST(MAKEDEPEND)
++MAKEDEPEND="$(which makedepend)"
+
+-if test -x "../nx-X11/config/makedepend/makedepend" ; then
+- MAKEDEPEND=../nx-X11/config/makedepend/makedepend
+-else
+- if test -x "/usr/X11R6/bin/makedepend" ; then
+- MAKEDEPEND=/usr/X11R6/bin/makedepend
+- else
+- if test -x "/usr/openwin/bin/makedepend" ; then
+- MAKEDEPEND=/usr/openwin/bin/makedepend
+- else
+- MAKEDEPEND=makedepend
+- fi
++# Try to desperately find makedepend.
++# Set MAKEDEPEND to the shipped makedepend binary. This will not
++# exist in nx-libs-lite, though, in which case MAKEDEPEND
++# will stay empty.
++if test -z "${MAKEDEPEND}"; then
++ if test -x "../nx-X11/config/makedepend/makedepend"; then
++ MAKEDEPEND="../nx-X11/config/makedepend/makedepend"
+ fi
+ fi
+
+--- a/nxcompshad/Makefile.in
++++ b/nxcompshad/Makefile.in
+@@ -179,9 +179,9 @@ depends: depend.status
+ depend: depend.status
+
+ depend.status:
+- if [ -x $(MAKEDEPEND) ] ; then \
++ if [ -n "$(MAKEDEPEND)" ] && [ -x "$(MAKEDEPEND)" ] ; then \
+ $(MAKEDEPEND) $(CXXINCLUDES) $(CCINCLUDES) \
+- $(DEPENDINCLUDES) -f Makefile $(MSRC) $(CSRC) $(CXXSRC) 2>/dev/null; \
++ $(DEPENDINCLUDES) -f Makefile $(MSRC) $(CSRC) $(CXXSRC) 2>/dev/null; \
+ fi
+ touch depend.status
+