aboutsummaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-01-27 13:56:36 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-01-28 11:35:59 +0100
commitb3d32ec569b8cd7efcb7a332d896eecd9681af02 (patch)
tree3c7e1d87ee226804e85e359dfe31bcdf67b0a198 /debian/patches
parenta3087eec9b048d308ae704f7a0540eaa416d4813 (diff)
downloadnx-libs-b3d32ec569b8cd7efcb7a332d896eecd9681af02.tar.gz
nx-libs-b3d32ec569b8cd7efcb7a332d896eecd9681af02.tar.bz2
nx-libs-b3d32ec569b8cd7efcb7a332d896eecd9681af02.zip
Fully rework the way nx-libs gets packaged for Debian/Ubuntu.
* Debian/Ubuntu packaging: + Fully rework the way nx-libs gets packaged for Debian/Ubuntu. + Split up libnx-x11 into individual packages. + Provide dbg:packages for each bin:package containing binaries. + Use Makefile logic to install files into DESTDIR. + Provide dev:packages for each lib:package individually. + Provide nx-x11proto-*-dev packages for all libnx-* libraries. + Install _all_ library files (*.so*) to /usr/lib/<triplet>/, so no extra settings of LD_LIBRARY_PATH is necessary.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/012_nxcomp_makefile-uninstall+autoconf.full+lite.patch18
-rw-r--r--debian/patches/013_nxcompext_makefile-uninstall+autoconf.full.patch14
-rw-r--r--debian/patches/014_nxcompshad_makefile-uninstall+autoconf.full.patch18
-rw-r--r--debian/patches/031_nx-X11_parallel-make.full.patch129
-rw-r--r--debian/patches/600_nx-X11+nxcompext+nxcompshad_unique-libnames.full.patch280
5 files changed, 50 insertions, 409 deletions
diff --git a/debian/patches/012_nxcomp_makefile-uninstall+autoconf.full+lite.patch b/debian/patches/012_nxcomp_makefile-uninstall+autoconf.full+lite.patch
index 9b9da7e31..af778fefc 100644
--- a/debian/patches/012_nxcomp_makefile-uninstall+autoconf.full+lite.patch
+++ b/debian/patches/012_nxcomp_makefile-uninstall+autoconf.full+lite.patch
@@ -36,12 +36,12 @@ Last-Update: 2012-02-14
install.bin:
+install.lib: all
-+ ./mkinstalldirs $(DESTDIR)${libdir}/nx
++ ./mkinstalldirs $(DESTDIR)${libdir}
+ ./mkinstalldirs $(DESTDIR)${includedir}/nx
-+ $(INSTALL_DATA) $(LIBFULL) $(DESTDIR)${libdir}/nx
-+ $(INSTALL_LINK) libXcomp.so.3 $(DESTDIR)${libdir}/nx
-+ $(INSTALL_LINK) libXcomp.so $(DESTDIR)${libdir}/nx
-+ $(INSTALL_DATA) libXcomp.a $(DESTDIR)${libdir}/nx
++ $(INSTALL_DATA) $(LIBFULL) $(DESTDIR)${libdir}
++ $(INSTALL_LINK) libXcomp.so.3 $(DESTDIR)${libdir}
++ $(INSTALL_LINK) libXcomp.so $(DESTDIR)${libdir}
++ $(INSTALL_DATA) libXcomp.a $(DESTDIR)${libdir}
+ $(INSTALL_DATA) NX*.h $(DESTDIR)${includedir}/nx
+ $(INSTALL_DATA) MD5.h $(DESTDIR)${includedir}/nx
+ echo "Running ldconfig tool, this may take a while..." && ldconfig || true
@@ -53,10 +53,10 @@ Last-Update: 2012-02-14
+uninstall.bin:
+
+uninstall.lib:
-+ $(RM_FILE) $(DESTDIR)${libdir}/nx/$(LIBFULL)
-+ $(RM_FILE) $(DESTDIR)${libdir}/nx/libXcomp.so.3
-+ $(RM_FILE) $(DESTDIR)${libdir}/nx/libXcomp.so
-+ $(RM_FILE) $(DESTDIR)${libdir}/nx/libXcomp.a
++ $(RM_FILE) $(DESTDIR)${libdir}/$(LIBFULL)
++ $(RM_FILE) $(DESTDIR)${libdir}/libXcomp.so.3
++ $(RM_FILE) $(DESTDIR)${libdir}/libXcomp.so
++ $(RM_FILE) $(DESTDIR)${libdir}/libXcomp.a
+ $(RM_FILE) $(DESTDIR)${includedir}/nx/NXalert.h
+ $(RM_FILE) $(DESTDIR)${includedir}/nx/NX.h
+ $(RM_FILE) $(DESTDIR)${includedir}/nx/NXmitshm.h
diff --git a/debian/patches/013_nxcompext_makefile-uninstall+autoconf.full.patch b/debian/patches/013_nxcompext_makefile-uninstall+autoconf.full.patch
index b704fc1bd..300c0a39e 100644
--- a/debian/patches/013_nxcompext_makefile-uninstall+autoconf.full.patch
+++ b/debian/patches/013_nxcompext_makefile-uninstall+autoconf.full.patch
@@ -37,11 +37,11 @@ Last-Update: 2012-02-14
install.bin:
+install.lib: all
-+ ./mkinstalldirs $(DESTDIR)${libdir}/nx
++ ./mkinstalldirs $(DESTDIR)${libdir}
+ ./mkinstalldirs $(DESTDIR)${includedir}/nx
-+ $(INSTALL_DATA) $(LIBFULL) $(DESTDIR)${libdir}/nx
-+ $(INSTALL_LINK) libXcompext.so.3 $(DESTDIR)${libdir}/nx
-+ $(INSTALL_LINK) libXcompext.so $(DESTDIR)${libdir}/nx
++ $(INSTALL_DATA) $(LIBFULL) $(DESTDIR)${libdir}
++ $(INSTALL_LINK) libXcompext.so.3 $(DESTDIR)${libdir}
++ $(INSTALL_LINK) libXcompext.so $(DESTDIR)${libdir}
+ $(INSTALL_DATA) NX*.h $(DESTDIR)${includedir}/nx
+ echo "Running ldconfig tool, this may take a while..." && ldconfig || true
+
@@ -52,9 +52,9 @@ Last-Update: 2012-02-14
+uninstall.bin:
+
+uninstall.lib:
-+ $(RM_FILE) $(DESTDIR)${libdir}/nx/$(LIBFULL)
-+ $(RM_FILE) $(DESTDIR)${libdir}/nx/libXcompext.so.3
-+ $(RM_FILE) $(DESTDIR)${libdir}/nx/libXcompext.so
++ $(RM_FILE) $(DESTDIR)${libdir}/$(LIBFULL)
++ $(RM_FILE) $(DESTDIR)${libdir}/libXcompext.so.3
++ $(RM_FILE) $(DESTDIR)${libdir}/libXcompext.so
+ $(RM_FILE) $(DESTDIR)${includedir}/nx/NXlib.h
+ $(RM_FILE) $(DESTDIR)${includedir}/nx/NXlibint.h
+ echo "Running ldconfig tool, this may take a while..." && ldconfig || true
diff --git a/debian/patches/014_nxcompshad_makefile-uninstall+autoconf.full.patch b/debian/patches/014_nxcompshad_makefile-uninstall+autoconf.full.patch
index 057763505..921eccc4f 100644
--- a/debian/patches/014_nxcompshad_makefile-uninstall+autoconf.full.patch
+++ b/debian/patches/014_nxcompshad_makefile-uninstall+autoconf.full.patch
@@ -38,12 +38,12 @@ Last-Update: 2012-02-14
install.bin:
+install.lib: all
-+ $(INSTALL_DIR) $(DESTDIR)${libdir}/nx
++ $(INSTALL_DIR) $(DESTDIR)${libdir}
+ $(INSTALL_DIR) $(DESTDIR)${includedir}/nx
-+ $(INSTALL_DATA) $(LIBFULL) $(DESTDIR)${libdir}/nx
-+ $(INSTALL_LINK) libXcompshad.so.3 $(DESTDIR)${libdir}/nx
-+ $(INSTALL_LINK) libXcompshad.so $(DESTDIR)${libdir}/nx
-+ $(INSTALL_DATA) *.a $(DESTDIR)${libdir}/nx
++ $(INSTALL_DATA) $(LIBFULL) $(DESTDIR)${libdir}
++ $(INSTALL_LINK) libXcompshad.so.3 $(DESTDIR)${libdir}
++ $(INSTALL_LINK) libXcompshad.so $(DESTDIR)${libdir}
++ $(INSTALL_DATA) *.a $(DESTDIR)${libdir}
+ $(INSTALL_DATA) *.h $(DESTDIR)${includedir}/nx
+ echo "Running ldconfig tool, this may take a while..." && ldconfig || true
+
@@ -54,10 +54,10 @@ Last-Update: 2012-02-14
+uninstall.bin:
+
+uninstall.lib:
-+ $(RM_FILE) $(DESTDIR)${libdir}/nx/$(LIBFULL)
-+ $(RM_FILE) $(DESTDIR)${libdir}/nx/libXcompshad.so.3
-+ $(RM_FILE) $(DESTDIR)${libdir}/nx/libXcompshad.so
-+ $(RM_FILE) $(DESTDIR)${libdir}/nx/libXcompshad.a
++ $(RM_FILE) $(DESTDIR)${libdir}/$(LIBFULL)
++ $(RM_FILE) $(DESTDIR)${libdir}/libXcompshad.so.3
++ $(RM_FILE) $(DESTDIR)${libdir}/libXcompshad.so
++ $(RM_FILE) $(DESTDIR)${libdir}/libXcompshad.a
+ for header in *.h; do $(RM_FILE) $(DESTDIR)${includedir}/nx/$$header; done
+ $(RM_DIR) $(DESTDIR)${libdir}/nx/
+ $(RM_DIR) $(DESTDIR)${includedir}/nx/
diff --git a/debian/patches/031_nx-X11_parallel-make.full.patch b/debian/patches/031_nx-X11_parallel-make.full.patch
index 1bacd1ab3..e87918a71 100644
--- a/debian/patches/031_nx-X11_parallel-make.full.patch
+++ b/debian/patches/031_nx-X11_parallel-make.full.patch
@@ -9,19 +9,13 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
---
nx-X11/Makefile | 64 +++++++++++++++++-----------------
nx-X11/config/imake/Makefile.ini | 1
- nx-X11/extras/Mesa/Makefile | 2 -
- nx-X11/extras/Xpm/Makefile.noX | 1
- nx-X11/extras/drm/linux-core/Makefile | 4 +-
- nx-X11/extras/drm/linux/Makefile | 4 +-
- nx-X11/extras/ttf2pt1/Makefile | 4 +-
nx-X11/lib/X11/Imakefile | 12 ++----
- nx-X11/lib/X11/Imakefile.NX.original | 12 ++----
nx-X11/programs/Xserver/Imakefile | 4 +-
10 files changed, 60 insertions(+), 69 deletions(-)
--- a/nx-X11/Makefile
+++ b/nx-X11/Makefile
-@@ -32,8 +32,8 @@ VERSSRC = $(CONFIGSRC)/util/printver.c
+@@ -32,8 +32,8 @@
VERSPROG = $(CONFIGSRC)/util/printver.exe
all:
@@ -32,7 +26,7 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
all-initial:
@echo Please use make World, or on NT use nmake World.Win32.
-@@ -57,8 +57,8 @@ World:
+@@ -57,8 +57,8 @@
@date
@echo ""
@if [ -f xmakefile ]; then \
@@ -43,7 +37,7 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
$(RM) xmakefile; \
fi
@if [ ! -f $(IRULESRC)/host.def ]; then \
-@@ -84,14 +84,14 @@ World:
+@@ -84,14 +84,14 @@
# fi
cd $(IMAKESRC) && $(MAKE) $(FLAGS) clean
$(MAKE) $(MFLAGS) Makefile.boot
@@ -65,7 +59,7 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
@echo ""
@date
@echo ""
-@@ -154,15 +154,15 @@ World.Win32:
+@@ -154,15 +154,15 @@
-if exist xmakefile.bak del xmakefile.bak
-if exist xmakefile ren xmakefile xmakefile.bak
$(IMAKE:/=\) -s xmakefile -I$(IRULESRC) $(IMAKE_DEFINES) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT_DIR)
@@ -87,7 +81,7 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
@echo :
@echo :
@echo Full build of $(RELEASE) complete.
-@@ -198,38 +198,38 @@ World.OS2:
+@@ -198,38 +198,38 @@
# a copy of every rule that might be invoked at top level
clean:
@@ -143,7 +137,7 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
+ ${MAKE} ${MAKE_OPTS} $@
--- a/nx-X11/config/imake/Makefile.ini
+++ b/nx-X11/config/imake/Makefile.ini
-@@ -21,7 +21,6 @@ IMAKEMDEP_CROSSCOMPILE = -DCROSSCOMPILE_
+@@ -21,7 +21,6 @@
SHELL = /bin/sh
RM = rm -f
MV = mv
@@ -151,83 +145,9 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
RM_CMD = $(RM) *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a \
tags TAGS make.log
NPROC = 1
---- a/nx-X11/extras/Mesa/Makefile
-+++ b/nx-X11/extras/Mesa/Makefile
-@@ -12,7 +12,7 @@ default: $(TOP)/configs/current
-
-
- doxygen:
-- (cd doxygen ; make) ; \
-+ (cd doxygen ; ${MAKE}) ; \
-
- clean:
- @for dir in $(SUBDIRS) ; do \
---- a/nx-X11/extras/Xpm/Makefile.noX
-+++ b/nx-X11/extras/Xpm/Makefile.noX
-@@ -32,7 +32,6 @@
-
- SUBDIRS= lib sxpm cxpm
-
--MAKE=make
- MFLAGS=-f Makefile.noX
- INSTALL= install -c
- CURRENT_DIR=.
---- a/nx-X11/extras/drm/linux-core/Makefile
-+++ b/nx-X11/extras/drm/linux-core/Makefile
-@@ -176,7 +176,7 @@ endif
- all: modules
-
- modules: includes
-- make -C $(LINUXDIR) $(GETCONFIG) SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
-+ ${MAKE} -C $(LINUXDIR) $(GETCONFIG) SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
-
- ifeq ($(HEADERFROMBOOT),1)
-
-@@ -246,7 +246,7 @@ clean cleandir:
- rm -rf $(CLEANFILES)
-
- $(MODULE_LIST)::
-- make DRM_MODULES=$@ modules
-+ ${MAKE} DRM_MODULES=$@ modules
-
- # Build test utilities
-
---- a/nx-X11/extras/drm/linux/Makefile
-+++ b/nx-X11/extras/drm/linux/Makefile
-@@ -184,7 +184,7 @@ endif
- all: modules
-
- modules: includes
-- make -C $(LINUXDIR) $(GETCONFIG) SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
-+ ${MAKE} -C $(LINUXDIR) $(GETCONFIG) SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
-
- ifeq ($(HEADERFROMBOOT),1)
-
-@@ -254,7 +254,7 @@ clean cleandir:
- rm -rf $(CLEANFILES)
-
- $(MODULE_LIST)::
-- make DRM_MODULES=$@ modules
-+ ${MAKE} DRM_MODULES=$@ modules
-
- # Build test utilities
-
---- a/nx-X11/extras/ttf2pt1/Makefile
-+++ b/nx-X11/extras/ttf2pt1/Makefile
-@@ -158,8 +158,8 @@ mans: $(MANS)
-
- clean:
- rm -f t1asm ttf2pt1 *.o app/RPM/Makefile app/RPM/*.spec *.core core.* core
-- ( cd other && make clean; )
-- ( cd app/netscape && make clean; )
-+ ( cd other && ${MAKE} clean; )
-+ ( cd app/netscape && ${MAKE} clean; )
-
- veryclean: clean
- rm -f $(DOCS) $(MANS)
--- a/nx-X11/lib/X11/Imakefile
+++ b/nx-X11/lib/X11/Imakefile
-@@ -1161,25 +1161,23 @@ $(NX_XCOMPEXTCONFIGTARGET):
+@@ -1161,25 +1161,23 @@
#ifdef SunArchitecture
$(NX_XCOMPLIBTARGET): $(NX_XCOMPCONFIGTARGET)
@@ -261,9 +181,26 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
all:: $(NX_XCOMPLIBTARGET)
+--- a/nx-X11/programs/Xserver/Imakefile
++++ b/nx-X11/programs/Xserver/Imakefile
+@@ -1045,11 +1045,11 @@
+ #ifdef SunArchitecture
+ $(NX_XSHADOWLIBTARGET): $(NX_XSHADOWCONFIGTARGET)
+ cd $(NX_XSHADOWLIBDIR) && \
+- gmake
++ ${MAKE}
+ #else
+ $(NX_XSHADOWLIBTARGET): $(NX_XSHADOWCONFIGTARGET)
+ cd $(NX_XSHADOWLIBDIR) && \
+- rm -f *.o && make
++ rm -f *.o && ${MAKE}
+ #endif
+
+ ServerTarget(nxagent,$(NX_XSHADOWLIBTARGET) $(NXAGENTDIRS),$(NXAGENTOBJS), \
+
--- a/nx-X11/lib/X11/Imakefile.NX.original
+++ b/nx-X11/lib/X11/Imakefile.NX.original
-@@ -1159,21 +1159,17 @@ $(NX_XCOMPEXTCONFIGTARGET):
+@@ -1159,21 +1159,17 @@
#ifdef SunArchitecture
$(NX_XCOMPLIBTARGET): $(NX_XCOMPCONFIGTARGET)
@@ -289,19 +226,3 @@ Last-Update: 2012-01-26 22:29:13.993994227 +0100
#endif
---- a/nx-X11/programs/Xserver/Imakefile
-+++ b/nx-X11/programs/Xserver/Imakefile
-@@ -1045,11 +1045,11 @@ $(NX_XSHADOWCONFIGTARGET):
- #ifdef SunArchitecture
- $(NX_XSHADOWLIBTARGET): $(NX_XSHADOWCONFIGTARGET)
- cd $(NX_XSHADOWLIBDIR) && \
-- gmake
-+ ${MAKE}
- #else
- $(NX_XSHADOWLIBTARGET): $(NX_XSHADOWCONFIGTARGET)
- cd $(NX_XSHADOWLIBDIR) && \
-- rm -f *.o && make
-+ rm -f *.o && ${MAKE}
- #endif
-
- ServerTarget(nxagent,$(NX_XSHADOWLIBTARGET) $(NXAGENTDIRS),$(NXAGENTOBJS), \
diff --git a/debian/patches/600_nx-X11+nxcompext+nxcompshad_unique-libnames.full.patch b/debian/patches/600_nx-X11+nxcompext+nxcompshad_unique-libnames.full.patch
index 4e6607e60..ebc77ecd0 100644
--- a/debian/patches/600_nx-X11+nxcompext+nxcompshad_unique-libnames.full.patch
+++ b/debian/patches/600_nx-X11+nxcompext+nxcompshad_unique-libnames.full.patch
@@ -41,22 +41,13 @@ Last-Update: 2012-02-15
nx-X11/config/cf/sv3Lib.tmpl | 24 +-
nx-X11/config/cf/sv4Lib.tmpl | 2
nx-X11/config/cf/usl.cf | 2
- nx-X11/extras/Mesa/src/mesa/main/Imakefile | 2
- nx-X11/extras/Xpm/lib/Imakefile | 2
- nx-X11/extras/drm/libdrm.pc.in | 2
- nx-X11/extras/fontconfig/fontconfig.pc.in | 2
- nx-X11/extras/ogl-sample/main/gfx/lib/glu/Imakefile | 2
- nx-X11/lib/FS/Imakefile | 2
nx-X11/lib/GLw/Imakefile | 2
- nx-X11/lib/ICE/Imakefile | 2
- nx-X11/lib/SM/Imakefile | 2
nx-X11/lib/X11/Imakefile | 2
nx-X11/lib/X11/Imakefile.NX.original | 2
nx-X11/lib/X11/Imakefile.X.original | 2
nx-X11/lib/XRes/Imakefile | 2
nx-X11/lib/XTrap/Imakefile | 2
nx-X11/lib/Xau/Imakefile | 2
- nx-X11/lib/Xaw/Imakefile | 2
nx-X11/lib/Xaw6/Imakefile | 2
nx-X11/lib/Xaw7/Imakefile | 2
nx-X11/lib/Xcomposite/Imakefile | 2
@@ -72,13 +63,9 @@ Last-Update: 2012-02-15
nx-X11/lib/Xfixes/Imakefile | 2
nx-X11/lib/Xfixes/xfixes.pc.in | 2
nx-X11/lib/Xfontcache/Imakefile | 2
- nx-X11/lib/Xft/Imakefile | 2
- nx-X11/lib/Xft/xft.pc.in | 2
nx-X11/lib/Xft1/Imakefile | 2
nx-X11/lib/Xi/Imakefile | 2
nx-X11/lib/Xinerama/Imakefile | 2
- nx-X11/lib/Xmu/Imakefile | 2
- nx-X11/lib/Xmuu/Imakefile | 2
nx-X11/lib/Xp/Imakefile | 2
nx-X11/lib/Xpm/Imakefile | 2
nx-X11/lib/Xpm/Imakefile.NX.original | 2
@@ -89,9 +76,6 @@ Last-Update: 2012-02-15
nx-X11/lib/Xrender/Imakefile | 2
nx-X11/lib/Xrender/xrender.pc.in | 2
nx-X11/lib/Xss/Imakefile | 2
- nx-X11/lib/Xt/Imakefile | 2
- nx-X11/lib/Xt/Imakefile.NX.original | 2
- nx-X11/lib/Xt/Imakefile.X.original | 2
nx-X11/lib/Xtst/Imakefile | 2
nx-X11/lib/Xv/Imakefile | 2
nx-X11/lib/XvMC/Imakefile | 2
@@ -107,20 +91,13 @@ Last-Update: 2012-02-15
nx-X11/lib/dmx/Imakefile | 2
nx-X11/lib/dps/Imakefile | 2
nx-X11/lib/dpstk/Imakefile | 2
- nx-X11/lib/expat/Imakefile | 2
nx-X11/lib/font/Imakefile | 2
- nx-X11/lib/fontconfig/Imakefile | 2
- nx-X11/lib/fontenc/Imakefile | 2
- nx-X11/lib/freetype2/Imakefile | 2
nx-X11/lib/oldX/Imakefile | 2
nx-X11/lib/psres/Imakefile | 2
- nx-X11/lib/regex/Imakefile | 2
nx-X11/lib/windows/Imakefile | 2
nx-X11/lib/xkbfile/Imakefile | 2
nx-X11/lib/xkbui/Imakefile | 2
- nx-X11/lib/zlib/Imakefile | 2
nx-X11/programs/Xserver/Imakefile | 18 -
- nx-X11/programs/Xserver/hw/xfree86/parser/Imakefile | 2
nxcompext/Makefile.in | 4
nxcompshad/Makefile.in | 4
103 files changed, 294 insertions(+), 294 deletions(-)
@@ -1243,68 +1220,6 @@ Last-Update: 2012-02-15
XMULIB = $(XMULIBONLY) $(XTOOLLIB) $(XLIB)
#endif
---- a/nx-X11/extras/Mesa/src/mesa/main/Imakefile
-+++ b/nx-X11/extras/Mesa/src/mesa/main/Imakefile
-@@ -2,7 +2,7 @@
- #define DoSharedLib YES
- #define DoDebugLib NO
- #define DoProfileLib NO
--#define LibName MESAGL
-+#define LibName NX_MESAGL
- #define SoRev SOX11REV
- #define LibHeaders NO
-
---- a/nx-X11/extras/Xpm/lib/Imakefile
-+++ b/nx-X11/extras/Xpm/lib/Imakefile
-@@ -125,7 +125,7 @@
- STD_DEFINES = LibraryDefines
- CDEBUGFLAGS = LibraryCDebugFlags
- #else
--#define LibName Xpm
-+#define LibName NX_Xpm
- #define SoRev SOXPMLIBREV
- #define IncSubdir X11
- /* we have to cheat on Library.tmpl to get what we want... */
---- a/nx-X11/extras/drm/libdrm.pc.in
-+++ b/nx-X11/extras/drm/libdrm.pc.in
-@@ -6,5 +6,5 @@
- Name: libdrm
- Description: Userspace interface to kernel DRM services
- Version: @PACKAGE_VERSION@
--Libs: -L${libdir} -ldrm
-+Libs: -L${libdir} -lNX_drm
- Cflags: -I${includedir} -I${includedir}/drm
---- a/nx-X11/extras/fontconfig/fontconfig.pc.in
-+++ b/nx-X11/extras/fontconfig/fontconfig.pc.in
-@@ -6,5 +6,5 @@
- Name: Fontconfig
- Description: Font configuration and customization library
- Version: @VERSION@
--Libs: -L${libdir} -lfontconfig
-+Libs: -L${libdir} -lNX_fontconfig
- Cflags: -I${includedir}
---- a/nx-X11/extras/ogl-sample/main/gfx/lib/glu/Imakefile
-+++ b/nx-X11/extras/ogl-sample/main/gfx/lib/glu/Imakefile
-@@ -36,7 +36,7 @@
- #define DoDebugLib DebugLibGlu
- #define DoProfileLib ProfileLibGlu
- #define IHaveSubdirs
--#define LibName GLU
-+#define LibName NX_GLU
- #define PassCDebugFlags 'CDEBUGFLAGS=$(CDEBUGFLAGS)'
- #define SoRev SOGLUREV
-
---- a/nx-X11/lib/FS/Imakefile
-+++ b/nx-X11/lib/FS/Imakefile
-@@ -11,7 +11,7 @@
- #define DoExtraLib SharedLibFS
- #define DoDebugLib DebugLibFS
- #define DoProfileLib ProfileLibFS
--#define LibName FS
-+#define LibName NX_FS
- #define SoRev SOFSREV
- #define IncSubdir X11
- #define IncSubSubdir fonts
--- a/nx-X11/lib/GLw/Imakefile
+++ b/nx-X11/lib/GLw/Imakefile
@@ -46,7 +46,7 @@
@@ -1316,28 +1231,6 @@ Last-Update: 2012-02-15
#define SoRev SOGLWREV
#define IncSubdir GL
---- a/nx-X11/lib/ICE/Imakefile
-+++ b/nx-X11/lib/ICE/Imakefile
-@@ -10,7 +10,7 @@
- #define DoExtraLib SharedLibICE
- #define DoDebugLib DebugLibICE
- #define DoProfileLib ProfileLibICE
--#define LibName ICE
-+#define LibName NX_ICE
- #define SoRev SOICEREV
- #define IncSubdir X11
- #define IncSubSubdir ICE
---- a/nx-X11/lib/SM/Imakefile
-+++ b/nx-X11/lib/SM/Imakefile
-@@ -10,7 +10,7 @@
- #define DoExtraLib SharedLibSM
- #define DoDebugLib DebugLibSM
- #define DoProfileLib ProfileLibSM
--#define LibName SM
-+#define LibName NX_SM
- #define SoRev SOSMREV
- #define IncSubdir X11
- #define IncSubSubdir SM
--- a/nx-X11/lib/X11/Imakefile
+++ b/nx-X11/lib/X11/Imakefile
@@ -82,7 +82,7 @@
@@ -1404,17 +1297,6 @@ Last-Update: 2012-02-15
#define SoRev SOXAUTHREV
#define IncSubdir X11
---- a/nx-X11/lib/Xaw/Imakefile
-+++ b/nx-X11/lib/Xaw/Imakefile
-@@ -11,7 +11,7 @@
- #define DoDebugLib DebugLibXaw
- #define DoProfileLib ProfileLibXaw
- #define HasSharedData YES
--#define LibName Xaw
-+#define LibName NX_Xaw
- #define SoRev SOXAWREV
- #define IncSubdir X11
- #define IncSubSubdir Xaw
--- a/nx-X11/lib/Xaw6/Imakefile
+++ b/nx-X11/lib/Xaw6/Imakefile
@@ -5,7 +5,7 @@
@@ -1565,36 +1447,6 @@ Last-Update: 2012-02-15
#define SoRev SOXFONTCACHEREV
#define LibHeaders NO
---- a/nx-X11/lib/Xft/Imakefile
-+++ b/nx-X11/lib/Xft/Imakefile
-@@ -8,7 +8,7 @@
- #define DoProfileLib ProfileLibXft
-
- #define HasSharedData YES
--#define LibName Xft
-+#define LibName NX_Xft
- #define SoRev SOXFTREV
- #define IncSubdir X11
- #define IncSubSubdir Xft
---- a/nx-X11/lib/Xft/xft.pc.in
-+++ b/nx-X11/lib/Xft/xft.pc.in
-@@ -9,4 +9,4 @@
- Requires: xrender, fontconfig, freetype2
- Requires.private: xrender, fontconfig, freetype2
- Cflags: -I${includedir}
--Libs: -L${libdir} -lXft
-+Libs: -L${libdir} -lNX_Xft
---- a/nx-X11/lib/Xft1/Imakefile
-+++ b/nx-X11/lib/Xft1/Imakefile
-@@ -70,7 +70,7 @@
- #define DoDebugLib NO
- #define DoProfileLib NO
- #define HasSharedData YES
--#define LibName Xft
-+#define LibName NX_Xft
- #define SoRev SOXFT1REV
- #define LibHeaders NO
- #define NoSoSymlink
--- a/nx-X11/lib/Xi/Imakefile
+++ b/nx-X11/lib/Xi/Imakefile
@@ -10,7 +10,7 @@
@@ -1617,28 +1469,6 @@ Last-Update: 2012-02-15
#define SoRev SOXINERAMAREV
#define LibHeaders NO
---- a/nx-X11/lib/Xmu/Imakefile
-+++ b/nx-X11/lib/Xmu/Imakefile
-@@ -11,7 +11,7 @@
- #define DoDebugLib DebugLibXmu
- #define DoProfileLib ProfileLibXmu
- #define HasSharedData YES
--#define LibName Xmu
-+#define LibName NX_Xmu
- #define SoRev SOXMUREV
- #define IncSubdir X11
- #define IncSubSubdir Xmu
---- a/nx-X11/lib/Xmuu/Imakefile
-+++ b/nx-X11/lib/Xmuu/Imakefile
-@@ -11,7 +11,7 @@
- #define DoExtraLib SharedLibXmuu
- #define DoDebugLib DebugLibXmuu
- #define DoProfileLib ProfileLibXmuu
--#define LibName Xmuu
-+#define LibName NX_Xmuu
- #define SoRev SOXMUUREV
- #define LibHeaders NO
-
--- a/nx-X11/lib/Xp/Imakefile
+++ b/nx-X11/lib/Xp/Imakefile
@@ -44,7 +44,7 @@
@@ -1746,39 +1576,6 @@ Last-Update: 2012-02-15
#define SoRev SOXSSREV
#define LibHeaders NO
---- a/nx-X11/lib/Xt/Imakefile
-+++ b/nx-X11/lib/Xt/Imakefile
-@@ -42,7 +42,7 @@
- #define DoDebugLib DebugLibXt
- #define DoProfileLib ProfileLibXt
- #define HasSharedData YES
--#define LibName Xt
-+#define LibName NX_Xt
- #define SoRev SOXTREV
- #define IncSubdir X11
-
---- a/nx-X11/lib/Xt/Imakefile.NX.original
-+++ b/nx-X11/lib/Xt/Imakefile.NX.original
-@@ -42,7 +42,7 @@
- #define DoDebugLib DebugLibXt
- #define DoProfileLib ProfileLibXt
- #define HasSharedData YES
--#define LibName Xt
-+#define LibName NX_Xt
- #define SoRev SOXTREV
- #define IncSubdir X11
-
---- a/nx-X11/lib/Xt/Imakefile.X.original
-+++ b/nx-X11/lib/Xt/Imakefile.X.original
-@@ -11,7 +11,7 @@
- #define DoDebugLib DebugLibXt
- #define DoProfileLib ProfileLibXt
- #define HasSharedData YES
--#define LibName Xt
-+#define LibName NX_Xt
- #define SoRev SOXTREV
- #define IncSubdir X11
-
--- a/nx-X11/lib/Xtst/Imakefile
+++ b/nx-X11/lib/Xtst/Imakefile
@@ -10,7 +10,7 @@
@@ -1944,17 +1741,6 @@ Last-Update: 2012-02-15
#define SoRev SODPSTKREV
#define LibHeaders NO
---- a/nx-X11/lib/expat/Imakefile
-+++ b/nx-X11/lib/expat/Imakefile
-@@ -6,7 +6,7 @@
- #define DoDebugLib DebugLibExpat
- #define DoProfileLib ProfileLibExpat
- #define HasSharedData YES
--#define LibName expat
-+#define LibName NX_expat
- #define SoRev SOEXPATREV
- #ifdef SharedLibtoolExpatRev
- #define SharedLibtoolRev SharedLibtoolExpatRev
--- a/nx-X11/lib/font/Imakefile
+++ b/nx-X11/lib/font/Imakefile
@@ -31,7 +31,7 @@
@@ -1966,39 +1752,6 @@ Last-Update: 2012-02-15
SOREV = $(SOFONTREV)
#ifndef SeparateSharedCompile
---- a/nx-X11/lib/fontconfig/Imakefile
-+++ b/nx-X11/lib/fontconfig/Imakefile
-@@ -7,7 +7,7 @@
- #define DoDebugLib DebugLibFontconfig
- #define DoProfileLib ProfileLibFontconfig
- #define HasSharedData YES
--#define LibName fontconfig
-+#define LibName NX_fontconfig
- #define SoRev SOFONTCONFIGREV
- #define LibInstall InstallFontconfigLibrary
- #define LibHeaders InstallFontconfigLibrary
---- a/nx-X11/lib/fontenc/Imakefile
-+++ b/nx-X11/lib/fontenc/Imakefile
-@@ -17,7 +17,7 @@
- #define DoSharedLib SharedLibFontEnc
- #define DoDebugLib DebugLibFontEnc
- #define DoProfileLib ProfileLibFontEnc
--#define LibName fontenc
-+#define LibName NX_fontenc
- #define SoRev SOFONTENCREV
- #define IncSubdir X11
- #define IncSubSubdir fonts
---- a/nx-X11/lib/freetype2/Imakefile
-+++ b/nx-X11/lib/freetype2/Imakefile
-@@ -11,7 +11,7 @@
- #define DoDebugLib DebugLibFreetype2
- #define DoProfileLib ProfileLibFreetype2
- #define HasSharedData YES
--#define LibName freetype
-+#define LibName NX_freetype
- #define SoRev SOFREETYPE2REV
- #ifdef SharedLibtoolFreetype2Rev
- #define SharedLibtoolRev SharedLibtoolFreetype2Rev
--- a/nx-X11/lib/oldX/Imakefile
+++ b/nx-X11/lib/oldX/Imakefile
@@ -10,7 +10,7 @@
@@ -2021,17 +1774,6 @@ Last-Update: 2012-02-15
#define SoRev SOPSRESREV
#define LibHeaders NO
---- a/nx-X11/lib/regex/Imakefile
-+++ b/nx-X11/lib/regex/Imakefile
-@@ -6,7 +6,7 @@
- #define DoDebugLib NO
- #define DoProfileLib NO
- #define HasSharedData NO
--#define LibName regex
-+#define LibName NX_regex
- #define LibHeaders NO
- #define LibInstall NO
- #define LibInstallBuild YES
--- a/nx-X11/lib/windows/Imakefile
+++ b/nx-X11/lib/windows/Imakefile
@@ -2,7 +2,7 @@
@@ -2065,17 +1807,6 @@ Last-Update: 2012-02-15
#define SoRev SOXKBUIREV
#define IncSubdir X11
#define IncSubSubdir extensions
---- a/nx-X11/lib/zlib/Imakefile
-+++ b/nx-X11/lib/zlib/Imakefile
-@@ -12,7 +12,7 @@
- #define DoDebugLib NO
- #define DoProfileLib NO
- #define HasSharedData NO
--#define LibName z
-+#define LibName NX_z
- #define SoRev SOZLIBREV
-
- ZLIBDIR = $(TOP)/extras/zlib
--- a/nx-X11/programs/Xserver/Imakefile
+++ b/nx-X11/programs/Xserver/Imakefile
@@ -313,7 +313,7 @@
@@ -2130,17 +1861,6 @@ Last-Update: 2012-02-15
#endif /* NXAgentServer */
#if defined(XnonServer) && XnonServer
---- a/nx-X11/programs/Xserver/hw/xfree86/parser/Imakefile
-+++ b/nx-X11/programs/Xserver/hw/xfree86/parser/Imakefile
-@@ -7,7 +7,7 @@
- #define DoDebugLib NO
- #define DoProfileLib NO
- #define HasSharedData NO
--#define LibName xf86config
-+#define LibName NX_xf86config
-
- #define UseDBMalloc NO
-
--- a/nxcompext/Makefile.in
+++ b/nxcompext/Makefile.in
@@ -42,12 +42,12 @@