aboutsummaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2012-02-14 23:34:51 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2012-02-14 23:34:51 +0100
commit9282c00e2aaa02404809fe317308ccbb4da3b0e8 (patch)
tree543e681326592e943e3ca449ea72a046c2a1da0a /debian/patches
parent6a96ae450fb469bec1f23ebe727f6f318bfe80db (diff)
downloadnx-libs-9282c00e2aaa02404809fe317308ccbb4da3b0e8.tar.gz
nx-libs-9282c00e2aaa02404809fe317308ccbb4da3b0e8.tar.bz2
nx-libs-9282c00e2aaa02404809fe317308ccbb4da3b0e8.zip
Update patch: 001_add-main-makefile.full+lite.patch, fix missing $(CONFIGURE) variable.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/001_add-main-makefile.full+lite.patch10
1 files changed, 6 insertions, 4 deletions
diff --git a/debian/patches/001_add-main-makefile.full+lite.patch b/debian/patches/001_add-main-makefile.full+lite.patch
index 9f4351f91..3c236b9f2 100644
--- a/debian/patches/001_add-main-makefile.full+lite.patch
+++ b/debian/patches/001_add-main-makefile.full+lite.patch
@@ -5,9 +5,11 @@ Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Last-Update: 2011-12-31
--- /dev/null
+++ b/Makefile
-@@ -0,0 +1,34 @@
+@@ -0,0 +1,36 @@
+#!/usr/bin/make -f
+
++CONFIGURE=./configure
++
+%:
+ ${MAKE} -C nxcomp $@
+ ${MAKE} -C nxproxy $@
@@ -23,12 +25,12 @@ Last-Update: 2011-12-31
+ echo "No testing for NX (redistributed)"
+
+build-lite:
-+ cd nxcomp && autoconf && ./configure && ${MAKE}
-+ cd nxproxy && autoconf && ./configure && ${MAKE}
++ cd nxcomp && autoconf && (${CONFIGURE}) && ${MAKE}
++ cd nxproxy && autoconf && (${CONFIGURE}) && ${MAKE}
+
+build-full:
+# in the full case, we rely on "magic" in the nx-X11 imake-based makefiles...
-+ cd nxcomp && autoconf && ./configure
++ cd nxcomp && autoconf
+ cd nxcompext && autoconf
+ cd nxcompshad && autoconf
+ cd nx-X11 && ${MAKE} World