aboutsummaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2011-11-19 17:08:40 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2011-11-19 17:08:40 +0100
commit954557e9014e14df2468ff5c0e08b7ef533bb071 (patch)
tree0df92e09da9863bbe25b8f0553d833ad4a7c341e /debian/patches
parent4076b4132f499bb349f9a82895014ea8229db9ff (diff)
downloadnx-libs-954557e9014e14df2468ff5c0e08b7ef533bb071.tar.gz
nx-libs-954557e9014e14df2468ff5c0e08b7ef533bb071.tar.bz2
nx-libs-954557e9014e14df2468ff5c0e08b7ef533bb071.zip
Add main Makefile via patch: 001_add-main-makefile.patch.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/001_add-main-makefile.patch36
-rw-r--r--debian/patches/series1
2 files changed, 37 insertions, 0 deletions
diff --git a/debian/patches/001_add-main-makefile.patch b/debian/patches/001_add-main-makefile.patch
new file mode 100644
index 000000000..cd179f01c
--- /dev/null
+++ b/debian/patches/001_add-main-makefile.patch
@@ -0,0 +1,36 @@
+Add main Makefile to build all NX subprojects in this source tree.--- /dev/null
++++ b/Makefile
+@@ -0,0 +1,33 @@
++#!/usr/bin/make -f
++
++all: build
++
++build: build-arch build-indep
++
++clean:
++ cd nx-X11 && test -f Makefile && make $@ || true
++ cd nxcomp && test -f Makefile && make $@ || true
++ cd nxcompext && test -f Makefile && make $@ || true
++ cd nxcompshad && test -f Makefile && make $@ || true
++ cd nxproxy && test -f Makefile && make $@ || true
++
++
++distclean:
++ cd nx-X11 && test -f Makefile && make clean || true
++ cd nxcomp && test -f Makefile && make $@ || true
++ cd nxcompext && test -f Makefile && make $@ || true
++ cd nxcompshad && test -f Makefile && make $@ || true
++ cd nxproxy && test -f Makefile && make $@ || true
++
++build-arch:
++ cd nxcomp && autoconf
++ cd nxcompext && autoconf
++ cd nxcompshad && autoconf
++ cd nx-X11 && make World
++ cd nxproxy && autoconf
++
++build-indep:
++
++install:
++
++uninstall:
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 000000000..9a8f69823
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+001_add-main-makefile.patch