aboutsummaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2011-12-05 09:42:05 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2011-12-05 09:42:05 +0100
commita2d77744db9adfba4bf30d03a1bed3256653fc3e (patch)
treea842676689acb484732d7e9c1cdc9f09c59ddabb /debian/patches
parentf4fac453574cd3e10c3e47073c97397682fc6679 (diff)
downloadnx-libs-a2d77744db9adfba4bf30d03a1bed3256653fc3e.tar.gz
nx-libs-a2d77744db9adfba4bf30d03a1bed3256653fc3e.tar.bz2
nx-libs-a2d77744db9adfba4bf30d03a1bed3256653fc3e.zip
Add install/uninstall stanza to main Makefile (via patch 001_add-main-makefile.patch).
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/001_add-main-makefile.patch12
1 files changed, 11 insertions, 1 deletions
diff --git a/debian/patches/001_add-main-makefile.patch b/debian/patches/001_add-main-makefile.patch
index c0f95b38e..f487ef711 100644
--- a/debian/patches/001_add-main-makefile.patch
+++ b/debian/patches/001_add-main-makefile.patch
@@ -1,6 +1,6 @@
--- /dev/null
+++ b/Makefile
-@@ -0,0 +1,33 @@
+@@ -0,0 +1,43 @@
+#!/usr/bin/make -f
+
+all: build
@@ -32,5 +32,15 @@
+build-indep:
+
+install:
++ cd nxcomp && make install
++ cd nxcompext && make install
++ cd nxcompshad && make install
++ cd nx-X11 && make install
++ cd nxproxy && make install
+
+uninstall:
++ cd nxcomp && make uninstall
++ cd nxcompext && make uninstall
++ cd nxcompshad && make uninstall
++ cd nx-X11 && make uninstall
++ cd nxproxy && make uninstall