aboutsummaryrefslogtreecommitdiff
path: root/debian/roll-tarballs.sh
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-02-14 15:29:25 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-02-14 16:14:31 +0100
commit53329e60938447850479858449a94f3d0467ef03 (patch)
tree3cbd950ee60f8dfe9916b3a8230ee982a0c0aae2 /debian/roll-tarballs.sh
parent1a824cfb54fa4a60a50b75923e4b32a2458d9404 (diff)
downloadnx-libs-53329e60938447850479858449a94f3d0467ef03.tar.gz
nx-libs-53329e60938447850479858449a94f3d0467ef03.tar.bz2
nx-libs-53329e60938447850479858449a94f3d0467ef03.zip
Provide wrapper scripts for launch NX components in $(src)/bin/.
The installation process copies NX wrapper scripts into $(srcbase)/bin/ before build time. Those wrapper scripts are now in place natively and need not to be copied prior to building NX. Packaging scripts with adaptation: debian/roll-tarballs.sh debian/rules debian/*.docs nx-libs.spec
Diffstat (limited to 'debian/roll-tarballs.sh')
-rwxr-xr-xdebian/roll-tarballs.sh10
1 files changed, 1 insertions, 9 deletions
diff --git a/debian/roll-tarballs.sh b/debian/roll-tarballs.sh
index 37c897a66..384bc57e8 100755
--- a/debian/roll-tarballs.sh
+++ b/debian/roll-tarballs.sh
@@ -116,15 +116,7 @@ for f in $(ls README* 2>/dev/null); do
mv -v $f doc/;
done
-mkdir -p bin/
-if [ "$MODE" = "lite" ]; then
- # copy wrapper script nxproxy only into tarball
- cp -v debian/wrappers/nxproxy bin/
-else
- # copy wrapper scripts into tarball
- for w in $(ls debian/wrappers/* 2>/dev/null); do
- cp -v $w bin/
- done
+if [ "$MODE" = "full" ]; then
# provide a default keystrokes.cfg file
mkdir -p etc
test -f etc/keystrokes.cfg || test -f debian/keystrokes.cfg && cp -v debian/keystrokes.cfg etc/keystrokes.cfg